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Preface

Maple Software

MapleTM software is a powerful system that you can use to solve mathematical problems from simple to complex. You
can also create professional quality documents, presentations, and custom interactive computational tools in the Maple
environment.

You can access the power of the Maple computational engine through a variety of interfaces.

Interface Description

Standard (default) A full-featured graphical user interface that helps you create electronic documents to show all
your calculations, assumptions, and any margin of error in your results. You can also hide the
computations to allow your reader to focus on the problem setup and final results. The advanced
formatting features lets you create the customized document you need. Because the documents
are /ive, you can edit the parameters and, with the click of a button, compute the new results.
The Standard interface has two modes: Document mode and Worksheet mode.

Classic A basic worksheet environment for older computers with limited memory. The Classic interface
does not offer all of the graphical user interface features that are available in the Standard
interface. The Classic interface has only one mode, Worksheet mode.

Command-line version A command-line interface for solving very large complex problems or batch processing with
scripts. No graphical user interface features are available.

MapletTM Applications Graphical user interfaces containing windows, textbox regions, and other visual interfaces,
which gives you point-and-click access to the power of Maple. You can perform calculations
and plot functions without using the worksheet.

Maplesoft™ Graphing Calculator | A graphical calculator interface to the Maple computational engine. Using it, you can perform
simple computations and create customizable, zoomable graphs. This is available on Microsoft®

Windows® only.

This manual describes how to use the Standard interface. As mentioned, the Standard interface offers two modes:
Document mode and Worksheet mode. Using either mode, you can create high quality interactive mathematical docu-
ments. Each mode offers the same features and functionality, the only difference is the default input region of each
mode.

Shortcut Keys by Platform

This manual will frequently refer to context menus and command completion when entering expressions. The keyboard
keys used to invoke these features differ based on your operating system.

This manual will only refer to the keyboard keys needed for a Windows operating system. The shortcut keys for your
operating system can be viewed from the Help menu (Help — Manuals, Resources, and more — Shortcut Keys).

Context Menus
« Right-click, Windows and UNIX®
¢ Control-click, Macintosh®

That is, place the mouse over the input or output region and press the right button on the mouse or press and hold the
Control key and click the mouse key for Macintosh.

For more information on Context Menus, see Context Menus (page 32).

Command Completion
* Esc, Macintosh, Windows, and UNIX

xiii
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* Ctrl + Space, Windows
« Ctrl + Shift + Space, UNIX

Begin entering a command in a Maple document. Press the Esc key. Alternatively, use the platform-specific keys. For
Windows, press and hold the Ctrl key and then press the Space bar.

For more information on Command Completion, see Command Completion (page 39).

In This Manual

This manual provides an introduction to the following Maple features:
» Ease-of-use when entering and solving problems

» Point-and-click interaction with various interfaces to help you solve problems quickly
* Maple commands and standard math notation

* Clickable Calculus

* The help system

* Online resources

* Performing computations

* Creating plots and animations

* The Maple programming language

 Using and creating custom Maplet applications

* File input and output, and using Maple with third party products

¢ Data structures

For a complete list of manuals, study guides, toolboxes, and other resources, visit the Maplesoft web site at
http://www.maplesoft.com

Audience

The information in this manual is intended for first-time Maple users and users looking for a little more information.

Conventions

This manual uses the following typographical conventions.

* bold font - Maple command, package name, option name, dialog, menu, or text field
* italics - new or important concept

* Note - additional information relevant to the section

* Important - information that must be read and followed

Customer Feedback

Maplesoft welcomes your feedback. For suggestions and comments related to this and other manuals, contact

doc@maplesoft.com.


http://www.maplesoft.com

1 Getting Started

Don't worry about your difficulties in Mathematics. I can assure you mine are still greater.
~Albert Einstein

Mathematics touches us every day—from the simple chore of calculating the total cost of our purchases to the complex

calculations used to construct the bridges we travel.

To harness the power of mathematics, Maplesoft provides a tool in an accessible and complete form. That tool is Maple.

1.1 In This Chapter

Section

Topics

Introduction to Maple (page 2) - The main features of Maple's
Standard Interface

Starting the Standard Document Interface

* Entering commands and mathematical expressions
* Toolbars

» Context menus

* Copy and drag keys

* Saving Maple documents

Entering Expressions (page 16) - Methods of entering
expressions in 1-D and 2-D Math

» Execution groups

* Math Mode and Text Mode
* Palettes

* Symbol names

* Toolbar icons

Point-and-Click Interaction (page 26) - An introduction to the
point-and-click features in Maple

+ Assistants

» Tutors

* Context menus
* Task templates

» Exploration Assistant

Commands (page 37) - An introduction to the commands of the
Maple language

+ Using commands from the Maple library
+ Entering commands

* Document blocks

The Maple Help System (page 43) - Accessing help on
commands, packages, point-and-click features, and more

* How to access help for Maple features
* Interacting with help pages

+ Viewing and interacting with examples

Available Resources (page 45) - Both online and from within
Maple

New user resources, including the Maple Tour and the Maple
Portal

» Examples
¢ Online help

* Maple web site resources
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1.2 Introduction to Maple
Working in Maple

With Maple, you can create powerful interactive documents. The Maple environment lets you start solving problems
right away by entering expressions in 2-D Math and solving these expressions using point-and-click interfaces. You
can combine text and math in the same line, add tables to organize the content of your work, or insert images, plots,
and sketch regions. You can visualize and animate problems in two and three dimensions, format text for academic
papers or books, and insert hyperlinks to other Maple files, web sites, or email addresses. You can embed and program
graphical user interface components, as well as devise custom solutions using the Maple programming language.

‘ Ch\Users\jwhitehead\Documents\SampleDocument.mw - [Server 3] - Maple 2016 EI@
File Edit View Insert Format Table Drawing Plot Spreadsheet Tools Window Help
DBHOEE 88 & BT) X == Gg> W1 O0HC & AQ @ @
Search for help, tasks, apps...
Palettes | waorkbook : Text m Drawing Plot Animation Hide :
M Favorites ol | L D mMath v| [ Times New Roman | [12 -] BH E%Z: l,ﬂ .E;E
P MapleCloud (Off) -
W Expression P4 ry— 63 ¥ dr+21 B ¥ — 6x+137 |plot([seg(Bessell(mx).n=1.4)Lx=0.10_filed)
a+b a—b ab x—0 x4+ 7 - x—1
0.5
:I_J (Jh ﬁ 10
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1) i
=g | ¥ ¥=a
1 Il B = =5
S 1 di_,f' dsolve( {¥'=a3.3(0) =3}) o) s o
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Jr"dr J_f'dr —xx<0
a = 4
x x=0 3
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' Common Symbols line y = x with the left half of the line y=-xas 2
e i J I o shown. 1
mfanu 4 -2 0 2 4
>> 3 2 << x
{ j; o = - ﬂ ==
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ENG IV — -]« 8
® Ready Maple Default Profile  C:\Users\jwhitehead\Documents Memory: 20.18M Time: 0.37s Zoom: 100% Math Mode

Figure 1.1: The Maple Environment
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Starting the Standard Document Interface

To start Maple on:

Windows From the Start menu, select All Programs — Maple 2016 — Maple 2016.
Alternatively:

Double-click the Maple 2016 desktop icon.
Macintosh 1. From the Finder, select Applications and Maple 2016.

2. Double-click Maple 2016.

UNIX Enter the full path, for example, /usr/local/maple/bin/xmaple

Alternatively:
1. Add the Maple directory (for example, /usr/local/maple/bin) to your command search path.

2. Enter xmaple.

When the first Maple session opens, a Start Page displays shortcuts to useful tasks and topics.

To start a Maple session:

* In the Start Page, select New Document or New Worksheet. A blank document displays.

or

* From the File menu, select New, and then either Document Mode or Worksheet Mode. A blank document displays.

Every time you open a document, Maple displays a Quick Help popup list of important shortcut keys. To invoke Quick
Help at any time, press the F1 key.

You can opt to start Maple with a blank document instead of the start page. You can also replace the default start page
with a custom start page. For instructions, refer to the startpage help page.

To invoke the Start Page at any time, click the home button (f7) on the worksheet toolbar.

Document and Worksheet Modes

Maple offers two modes, Document Mode and Worksheet Mode. Using either mode, you can create high quality inter-
active mathematical documents. Each mode offers the same features and functionality; the only difference is the default
input region of each mode.

Document Mode

Document mode uses Document Blocks as the default input region to hide Maple syntax. A Document Block region

is indicated by two triangles located in the vertical Markers column along the left pane of the Maple Document, >
If the Markers column is not visible, open the View menu and select Markers. This allows you to focus on the problem
instead of the commands used to solve the problem. For example, when using context menus on Maple input in Document
mode (invoked by right-clicking or Control-clicking for Macintosh), input and output are connected using an arrow
or equal sign with self-documenting text indicating the calculation that had taken place. The command used to solve
this expression is hidden.

ke . .
ZxQ+?x+ IDL{x=—2_I, {x=-—5}

To create a new document, select File — New — Document Mode.
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Worksheet Mode

Worksheet mode uses a Maple prompt as the default input region. The Maple input prompt is a red angle bracket, [::-.
When using context menus on input in Worksheet mode, all commands are displayed.

[ #erspn
> solve( {24+ T*x+10=01})
{x=-=12}, {x=-5}

To create a new worksheet, select File — New — Worksheet Mode.

Full Flexibility in Either Mode

Regardless of which mode you begin working in, you have the opportunity to use both document blocks and command
prompts.

For example, you can hide commands in Worksheet Mode by adding a document block from the Edit menu, Edit —
Document Blocks— Create Document Block (see Document Blocks (page 41)), or you can show commands in
Document mode by adding a Maple prompt from the Insert menu, Insert — Execution Group — Before / After
Cursor (see Input Prompt (page 62)).

This chapter discusses features common to both modes. Specific aspects of Document mode are explained in Document
Mode (page 49), and aspects of Worksheet mode are explained in Worksheet Mode (page 61).

The Maple Workbook

The Maple Workbook acts as a container that lets you collect: Maple worksheets, library archives and language files,
data (such as images or spreadsheets),and other items

into a single file, stored in the .maple file format . This lets you better organize your Maple-based projects. For more
information, see Workbook Overview.

Navigation of Workbook files is accomplished through the workbook explorer palette, available in the Workbook tab.
For more information, see Workbook Explorer.

Entering 2-D Math

In Maple, the default format for entering mathematical expressions is 2-D Math. This results in mathematical expressions
that are equivalent to the quality of math found in textbooks. Entering 2-D Math in Maple is done using common key
strokes or palette items. For more information on palettes, see Palettes (page 18). An example of entering an expression
using common key strokes is presented in the following section. An example of entering an expression using palette
items is presented in Example 3 - Enter an Expression Using Palettes (page 22).

Common Operations

Entering mathematical expressions, such as % + %, X + X, and Xy is natural in 2-D Math.

To enter a fraction starting with the numerator:
1. Enter the numerator.

2. Press the forward slash (/) key.

3. Enter the denominator.

4. To leave the denominator, press the right arrow key.
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To enter a fraction starting with the denominator:

1. Enter the denominator.

2. Press // (two forward slashes).

3. Enter the numerator.

4. To leave the numerator, press the right arrow key.

To enter a power:
1. Enter the base.
2. Press the caret (") key.

3. Enter the exponent, which displays in math as a superscript.

4. To leave the exponent, press the right arrow key.

To enter a product:

1. Enter the first factor.

2. Press the asterisk (*) key, which displays in 2-D Math as a dot, -.

3. Enter the second factor.

Implied Multiplication:

In most cases, you do not need to include the multiplication operator, . Insert a space character between two quantities

to multiply them.

Note: In some cases, you do not need to enter the multiplication operator or a space character. For example, Maple
interprets a number followed by a variable as multiplication.

Important: Maple interprets a sequence of letters, for example, xy, as a single variable. To specify the product of two

variables, you must insert a space character (or multiplication operator), for example, x y or X-y. For more information,
refer to the 2DMathDetails help page.

Shortcuts for Entering Mathematical Expressions

Table 1.1: Common Keystrokes for Entering Symbols and Formats

Symbol/Formats Key Example
implicit multiplication Space key ( 2_7 Xy+3 )/2) Xy

. s hift + * .
explicit multlphcatlon1 Shi 23
fraction2 / (forward slash) 1

// (two forward slashes) 4
. Shift + ~
exponent (superscript) 2 ! X
. .2 Ctrl + Shift + _ (Command + Shift + _in|
indexed subscript Macintosh) a
literal subscript (subscripted __ (two underscores) X
max

variable name)

navigating expressions

Arrow keys
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Symbol/Formats Key Example

* Esc in Macintosh,Windows, and UNIX | 44
» Ctrl + Space in Windows
+ Ctrl + Shift + Space in UNIX

command / symbol completion3

about (assumptions and properties)  abouf|expr |
abreve i

abs 1%l
abs ahs
abselsol (First order  DETools |abelsol || GDE, 3|

square root sqrt and then command completion m

. . exp and then command completion
exponential functlon2 P p e®

enter / exit 2-D Math * FS5key

) . 1 versus 1/4
* Math and Text icons in the toolbar 4

! required for products of numbers

2 . . . . .
use the right arrow key to leave a denominator, numerator, superscript, or subscript region

3 for more information, see Command Completion (page 39).

For a complete list of shortcut keys, refer to the 2-D Math Shortcut Keys and Hints help page. To access this help
page in the Maple software, in Math mode enter ?MathShortcuts and then press Enter. For information on the Maple
Help System, see The Maple Help System (page 43).

Example 1 - Enter and Evaluate an Expression Using Keystrokes
Review the following example:

X+y
2

In this example, you will enter and evaluate the expression.

X +y
2

Action Result in Document
To enter the expression: Ej

1. Enter x.

2. Press Shift + ~ . The cursor moves to the superscript position. XJ‘

3. Enter 2.

A

4. Press the right arrow key. The cursor moves right and out of the superscript position. ﬂ

5. Enter the + symbol.

24

6. Entery.

=+
2y

8. Enter 2 and press the right arrow key. 24 ﬂ

7. Press Shift + * to move to the superscript position.
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Action

Result in Document

9. With the mouse, select the expression that will be the numerator of the fraction.

x4y

10. Enter the / symbol. The cursor moves to the denominator, with the entire expression in
the numerator.

4y
f

11. Enter 2.

21y
E

12. Press the right arrow key to move right and out of the denominator position.

21y

2 |

To evaluate the expression and display the result inline:

13. Press Ctrl + = (Command + = in Macintosh).

Xy 1
%f X2+5)/2

1
2

To execute 2-D Math, you can use any of the following methods.

* Pressing Ctrl + = (Command + = in Macintosh). That is, press and hold the Ctrl (or Command) key, and then

press the equal sign (=) key. This evaluates and displays results inline.

 Pressing the Enter key. This evaluates and displays results on the next line and centered.

» Right-click (Control-click for Macintosh) the input to invoke a context menu item. From the context menu, select

Evaluate and Display Inline. See Context Menus (page 32) for more details.

* Using the Edit menu items Evaluate and Evaluate and Display Inline.

Toolbar Options

The Maple toolbar offers several buttons to assist you when interacting with Maple. See Table 1.2.

Table 1.2: Maple Toolbar Options

Basic Usage

Equivalent Menu Option or
Command

Create a new Maple document

From the File menu, select New and
then Document Mode

Open an existing document or worksheet

From the File menu, select Open...

Save the active document or worksheet

From the File menu, select Save...

Print the active document or worksheet

From the File menu, select Print...

Print preview the active document or worksheet

From the File menu, select Print
Preview...

Cut the selection to the clipboard

From the Edit menu, select Cut

Copy the selection to the clipboard

From the Edit menu, select Copy

Paste the clipboard contents into the current document
or worksheet

From the Edit menu, select Paste

Undo the last operation

From the Edit menu, select Undo

Redo the last operation

L (9 (B0 RN AT &l &

From the Edit menu, select Redo
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Basic Usage

Equivalent Menu Option or
Command

Insert the Code Edit Region

From the Insert menu, select Code
Edit Region

Inserts plain text after the current execution group.

From the Insert menu, select Text.

Inserts Maple Input after the current execution group.
For details, refer to Execution Groups (page 16).

From the Insert menu, select
Execution Group and then After
Cursor

Encloses the selection in a document block. If nothing
is selected, it creates a new document block.

IR I |

From the Edit menu, select Document
Blocks and then Create Document
Block

Encloses the selection in a subsection. For details,
refer to Sections (page 231).

v

From the Format menu, select Indent

Removes any section enclosing the selection.

From the Format menu, select
Outdent

Move backward to previous document in the hyperlink
history

Open the start page

Move forward to next document in the hyperlink
history.

BR[|

Executes all commands in the worksheet or document

From the Edit menu, select Execute
and then Worksheet.

Executes a selected area.

From the Edit menu, select Execute
and then Selection.

Interrupt the current operation.

Debug the current operation

Clears Maple's internal memory. For details, refer to
the restart help page.

Enter restart.

Add and edit Maple code that is executed each time
the worksheet is opened. For details, refer to the
startupcode help page.

e
LS

t4

3| Q2B —

{-'x.

From the Edit menu, select Startup
Code.

Adjusts the display size of document content. Note:
Plots, images, and sketches remain unchanged.

From the View menu, select Zoom
Factor and then a zoom size.

Toggle entry of tab characters with Tab key

Opens the Maple help system in a new window. For
details, refer to The Maple Help System (page 43).

From the Help menu, select Maple
Help.

Search box provides quick access to the help system.

For 1-D Math and text regions, the Tab icon in the toolbar allows you to set the Tab key to move between placeholders

(or cells in a table) or to indent text.

Table 1.3: Tab Icon Description

Tab Icon Description
—3 Tab icon off. Allows you to move between placeholders using the Tab key.
le—

N Tab icon on. Allows you to indent in the worksheet using the Tab key.
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Tab Icon Description
T The Tab icon is disabled when using 2-D Math (Math mode), and as such, the Tab key allows you to
move between placeholders.

Toolbar icons are controlled by the location of the cursor in the document. For example, place the cursor at an input
region and the Text and Math icons are accessible while the others are dimmed. See Table 1.4 for a list of the tools

available in each icon.

Table 1.4: Toolbar Icons and their Tools

Toolbar Icon Options

Text tools
Math Drawing Plot Animation
[C e -] [ @~ BIU EH== Lg =i
Math tools
Text Drawing Plot Animation
| C 2 Math ~ | [ Times New Roman ][ 12 ~] Bu E%Z: I g i=i=

Drawing tools

Text Math Plot Animation

N QENCOOOCE-D B~ — 3]

2-D Plot tools

Text Math Drawing Animation

- el [y LR AR b HEEE

3-D Plot tools

Text Math Drawing Animation
Ol s [Bwl s [B@ o [ W- W~ 11 ¢E+AQARLS

Animation tools

Text Math Drawing Plot

|4 m p p|current Frame |1 Ji | T ;| LB E A N

Table 1.5: Toolbar Icon Availability

Region Available Tools

Input region Text and Math icons

Plot region Drawing and Plot icons

Animation region Drawing, Plot, and Animation icons
Canvas and Image regions Drawing icon

The Text and Math icons allow you to enter text and math in the same line by choosing the appropriate input style at

each stage when entering the sentence.

sin(x) is cos(x)

For an example, see Example 6 - Enter Text and 2-D Math in the Same Line Using Toolbar Icons (page 25).

The meaning of the Text and Math icons differs while at a Maple input prompt. The Math icon displays input as 2-D
Math, whereas the Text icon displays Maple input. For details, refer to Math Mode vs. Text Mode (page 16).
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X

> A
2

> x*2/2;

To access the tools available in the Plot and Drawing icons, click a plot region. These tools allow you to manipulate

the plot or draw shapes and enter text on the plot region. By clicking an animation region, you have the same features

available for a plot region, in addition to tools for playing the animation in the Animation icon. For details on plots
and animations, refer to Plots and Animations (page 187).

For the remaining icons, hover the mouse over the icon to display the icon description.
Context Menus and Copy & Drag

Context Menus

Maple dynamically generates a context menu of applicable options when you right-click an object, expression, or region.
The options available in the context menu depend on the selected input region. For example, you can manipulate and
graph expressions, enhance plots, format text, manage palettes, structure tables, and more. When using context menus
to perform an action on an expression, the input and output are connected with a self-documenting arrow or equal sign
indicating the action that had taken place. For more information, see Context Menus (page 32).

Copy & Drag

With Maple, you can drag input, output, or curves in a plot region into a new input region. This is done by highlighting
the input or selecting the curve and dragging it with your mouse into a new input region. Dragging the highlighted region
will cut or delete the original input. To prevent this, use the copy and drag feature.

o Ctrl + drag, Windows and UNIX

* Command + drag, Macintosh

That is, highlight the region you want to copy. Press and hold the Ctrl key while you drag the input to the new region
using the mouse. The steps are the same for Macintosh with the exception of pressing the Command key.

Example 2 - Solve and Plot an Equation Using Context Menus and Copy & Drag

Review the following example:
5x—7=3x+2

In this example, we will enter the equation and then solve and plot the equation using context menus and Maple's copy
& drag feature. This example will only refer to the keystrokes needed on a Windows operating system to invoke the
context menus and the copy & drag feature. For your operating system, refer to section Shortcut Keys by

Platform (page xiii) for the equivalent keystrokes.
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To solve the equation:

1. Enter the equation.

2. Right-click the equation and select Move to Left.

Input:

Sx—T=3x+2

Result:

5x—7=3x+2

move to left
_—

Copy Special
Paste

Ewvaluate and Display Inline Chrl4+=

Explore

Apply & Command
Differentiate
Ewaluate at & Point
Integrate

Left-hand Side
Manipulate Equation
Map Command Onka
Mowe ko Left

Mave ka Right
Megate Felation
Flots

Right-hand Side
SinpliFy

Solve

Tesk Relation

Canversions
Integral Transforms
Sequence

2-D Math

2x—9=0

A brief description, "move to left" is displayed above the arrow that connects the input and output.

3. Right-click the output from the previous action, 2 x — 9 = 0, and select Solve — Isolate Expression for — x.
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Input:
Sx—T=3x+ 22l 9=0

Copy Special ]

Mumeric Farmatting...

Explore

Apply a Command

Differentiate »

Evaluate at a Paoint

Integrate ]

Left-hand Side

Manipulate Equation

Map Caormand Onto

Move bo Right

MNegate Relation

Plots »

Right-hand Side

Simplify ]

Salve » Isnolate Expression For

Test Relation Mumerically Solve
Murmerically Solve (wfcompla:)

onversions ' Mumerically Solve From point

Integral Transforms ] obkain Solltions Far

Sequence ] Salve
Solve (explicit)
Solve (general solution)
Solve For Variable

Result:

<]

move to left isolate for x

5x—7=3x4+42 —— 2x—9=0 —— x=
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Now that we have solved the equation, we can plot it. To do this, we will copy the equation 2 X — 9 = 0 to a new document block
and use context menus again.

4. From the Format menu, select Create Document Block.

5. To copy the expression 2 X — 9 = 0, highlight only this expression from the previous result. Press and hold the Ctrl key and
drag the expression to the new document block region.

Result:

to left 1s0late fi
Sx—T=3x4 grevelolefl o g okt forx 2

e to left izolate for x ad

5x—7=3x+24>2x—9=04>x=?

v 1o left isalate f
Sx—F=3x4 g Rl g Selteforx

> 2x—9=0

—=

R v v 2
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To plot the expression:

6. Right-click the equation, and select Left-hand Side.

Input:
2x—9=0
Copy Special »
Paste ChrlY
Evaluate and Display Inline Ctrl+=
Explore
Apply a Command
Differentiate »
Evaluate at a Point
Integrate ]
Left-hand Side
Manipulate Equation %
MMap Command Onko
Mave ka Right
Megate Felation
Flots »
Right-hand Side
SinpliFy ]
Solve ¥
Tesk Relation
Canversions [
Integral Transforms »
Sequence ]
2-0 Math ]
Result:

left hand sid
2Xx—9=0 — S, Hx—9

7. Right-click the expression and select Plots — 2-D Plot.
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15

Input:

2x—9

Copy Special
Paste

Evaluate and Display Inline Ctrl+=

Explore

Apply a Command
Assign bo a Marme
Coefficients
Collect
Differentiate
Ewaluate at & Point
Factor

Integrate

Lirnit

Flots

Series

SinpliFy

Solve

Complex Maps
Canstructions
Canversians

Integer Functions
Integral Transforms
Language Conversions
Optimization

Sequence

Sorts

Urits

2-D Math

- v v v

* T T T F T ¥ ¥ ¥ ¥

2-D Plat

3-D Plot (]
2-D Implicik Plat »
3-0 Implicit; Plot »
Plot Builder
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Result:
2x—9 —
10
-10 -5 0 5 10

Saving a Maple Document

To save these examples you created, from the File menu, select Save. Maple documents are saved as .mw files.

Saving a Maple Document as a Workbook

To save these examples you created as part of a new Maple workbook, from the Workbook tab, click Save As
Workbook. For more information about saving Maple content see worksheet,managing,saving

1.3 Entering Expressions

Execution Groups

An execution group is a grouping of Maple input with its corresponding Maple output. It is distinguished by a large
square bracket, called a group boundary, at the left. An execution group may also contain any or all of the following:
a plot, text, embedded components, and a drawing canvas.

Execution groups are the fundamental computation and documentation elements in the document. If you place the
cursor in an input command and press the Enter or Return key, Maple executes all of the input commands in the
current execution group.

Math Mode vs. Text Mode

The default mode of entry in Document or Worksheet mode is Math Mode, which displays input in 2-D Math. In
earlier releases of Maple, commands and expressions were entered using Maple Input or 1-D Math.

> cos(alpha)“~2+sin(alpha)*2;

cos(oc)2 + sin(oc)2
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> a*int (exp(sqrt(2) *x) ,x) ;

> limit (f(x) ,x=infinity) ;

> sum(al[k]*x*k, k=0..m)=product(b[j]*x*j, j=0..n);

Sax-Ti (9

In Document Mode, to enter input using Maple Input mode, insert a Maple prompt by clicking [* in the toolbar, and
then click the Text button in the toolbar. In Worksheet Mode, simply click the Text button. See Figure 1.2.

[lr.'n-:ilnj

[ C 2pmath

Plot Animation

v (1 v

- | ':\ Times Mew Roman

Figure 1.2: Text and Math Buttons on the Toolbar

Table 1.6: Math Mode vs. Text Mode

Math Mode

Text Mode

Maple's default setting. Executable standard math notation.
This is also referred to as 2-D Math Input.

>Jx2+2x+ldx

1
§X3+X2+x

Executable Maple notation. This is also referred to as 1-D
Math Input or Maple Input.

>int (x*2+2*x+1, x);

1
§x3+x2+x

Access from the Insert — 2-D Math menu.

Access from the Insert — Maple Input menu.

When using 2-D Math, the Math mode icon is highlighted in the

toolbar, Text

When entering Maple Input or text in a text region, the Text mode

icon is highlighted in the toolbar, Math

In Document Mode (or a document block), input is entered in a

document block with a slanted cursor, < L

In Document Mode (or a document block), input is entered with
a vertical cursor, as plain text, | >< Enter some text .

In Worksheet Mode, input is made at an input prompt with a

slanted cursor, [3" [ .

In Worksheet Mode, input is made at an input prompt with a

vertical cursor, [} | .

To convert a 2-D Math expression to 1-D Math, right-click the
expression (Command-click, Macintosh) and select 2-D Math
— Convert To — 1-D Math Input.

To convert a 1-D Math expression to 2-D Math, right-click the
expression (Command-click, Macintosh) and select Convert To
— 2-D Math Input.

Palettes make entering expressions in familiar notation easier
than entering foreign syntax and reduces the possibility of
introducing typing errors.

W Expression

[fdx—]%f-cbr——?—‘[fdx

Using palettes while in 1-D Math teaches you the related Maple
command syntax.

W Expression

b

[fd.x ._]Lf-gor——’[} int{f, x);
@

If you prefer 1-D Math input, you can change the default math input notation.



18 + 1 Getting Started

To change math input notation for a session or globally across all documents:
1. From the Tools menu, select Options. The Options Dialog opens.

2. Click the Display tab.

3. In the Input Display drop-down list, select Maple Notation.

4. Click the Apply to Session or Apply Globally button.

Important: The new input display becomes the default setting after pressing the Enter key.

Palettes

Palettes are collections of related items that you can insert into a document by clicking or drag-and-dropping. The

Maple environment provides access to over 30 palettes containing items such as symbols (), layouts (Ab), math-

b
ematical operations [J- f de, and much more.
a

By default, palettes are displayed in the left pane of the Maple environment when you launch Maple. If the palettes
are not displayed,

1. From the View menu, select Palettes.
2. Select Expand Docks.
3. Right-click (Control-click, Macintosh) the palette dock. From the context menu, select Show All Palettes.

Alternatively, from the main menu, select View — Palettes — Arrange Palettes to display specific palettes.

You can create a Favorites palette of the expressions and entities you use often by right-clicking (Control-click,
Macintosh) the palette template you want to add and selecting Add To Favorites Palette from the context menu.

Table 1.7: Palette Categories

Palette Category Palette Description
Alphabetical Palettes Greek,
Scriptﬂ,
w7 Gresk 9
ABTDAE 7 Fraktur R
Open Face C,
HO® I KAM pen *‘;Ie{
L Cyrillic 1
NZOMNPZX Y
moy Diacritical Marks * ,
I' Y Y DX W
5 Roman Extended Upper Case A,
Q o €
B T Roman Extended Lower Case & .
el n o 1
K x A puv g
O T wpPpeoo
STV O Y
Wy oW
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Palette Category

Palette Description

Mathematical Palettes

W Comman Symbals

Teij I w
> [ d NU
b e
£ £ o =~ =
= = s = 2 B
N@ IV - A
VYy=CRN
SZRs |
"+ —-x / F
T o % o v
I X h 2 |

Palettes for constructing expressions
Common Symbols,

Relational = "

Relational Round = s

Operators =,

Large Operators % s
Negated 7,

Fenced {{ s

Arrows 77,

Constants and Symbols ©0 .

Punctuation - insert punctuation symbols, such as inserting the registered trademark and

copyright symbols © into text regions

Miscellaneous - insert miscellaneous math and other symbols outside the above categories
&=

Expression Palettes

W Matriz
Rowas: 2
Calurnins: 7

| Choose... |

Shape: (Any v
Datatvpe: (Any ¥
| Insert Matrixz

Type: | Custom valuss * |

log, () .

Expression - construct expressions such as logarithms

Matrix - enter the number of rows and columns required, designate type, such as zero-filled,
and designate shape, such as diagonal.

Layout - add math content that has specific layout, such as expressions with one or more

A
superscripts and subscripts

b
Fdx
Calculus - construct expressions such as integrals -z
Handwriting - an easy way to find a desired symbol.
Units (SI) - insert a unit from the International System of Units (SI), or any general unit
[xg] .
Units (FPS) - insert a unit from the Foot-Pound-Second System (FPS), or any general unit
[21.

Y
Accents - insert decorated names, such as an X with an arrow over it to denote a vector 4 .

Trigonometric & Hyperbolic - a palette for constructing expressions containing
trigonometric and hyperbolic functions

Student Random Variables - a palette for constructing random variables based on
distributions in the Student Statistics package

Group Constructors - a palette for constructing groups based on the Group Theory package
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Palette Category Palette Description
Other Palettes Components - embed graphical interface components such as a button into your document
e or worksheet. Components can be programmed to perform an action when selected such as
W Compaonents executing a command when a button is clicked.
Butkon
;] Favorites - add templates that you use most often from other palettes.

MapleCloud - view worksheets shared by other users and share your worksheets.
jCombo Box - Variables - manage all of your assigned variables in your current Maple session.
[7] Check Box
@ Radio Butten

Text Area
Label
List Box

!
J
&

Task Palettes Live Data Plots - templates for visual representation of your data.

w Live Data Plots eBook Metadata - markup tags for use when creating eBooks from Maple worksheets

N

i Generate Area Chart

rae

|
I

- Tasks - a palette where you can store tasks that you have created
_—

Viewing and Arranging Palettes

By default, palettes display in palette docks at the right and left sides of the Maple window. To view and manage
palettes and palette docks, see Table 1.8.
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Table 1.8: Managing Palettes

To view palette docks:

* From the View menu, select Palettes, and then Expand
Docks. There are docks on the far right and left of the
window.

View  Insert  Format
Mext Tab

Previous Tab

v Toolbar
v Context Bar
v Stakus Bar
Markers
Task Elements

Slideshiow

Palettes

Zoarm Fackar
Twpesetting Rules., .,
ShoviHide Contents. ..
Header Footer...

Expand All Sections

Arrange Palettes. .,
Show Palette ]
Show all Palettes

Shows Defaulk Palettes

Expand All Palettes
Collapse all Palettes

Expand Docks
Collapse Docks

To add a palette:

1. Right-click the palette dock. Maple displays a context
menu near the palette.

2. From the context menu, select Show Palette and then
select the palette.

[ Arrange Palettes...
Show Palette
Show All Palettes
Show Default Palettes

Expand All Palettes
Collapse All Palettes

Expand Docks
Collapse Docks

Favorites
MapleCloud
Variables
Expression
Calculus
Matrix
Layout
Components
Handwriting
Units (D)

Units (FPS)

Accents
Student Randem Variables
Trigenometric and Hyperbelic Functions

Group Constructors

Rrrnan Fvtenred |lnner Cace

To expand or collapse a palette in the palette dock:

* Click the triangle at the left of the palette title.

LE2BsSEd BB o

@vorites

.A‘
' »

| ffd* %

e ®

1A
%

=

W Expression
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To move a palette in the palette dock:

palette to the new location.

* Move the palette by clicking the title and dragging the

W Fawarites | 'AE:
; !
e -

-
o® 4 ' -
[bExpression |

[b Zommon Symbols . |

To expand or collapse the palette docks:

side of the palette region.

 Select the appropriate triangle at the top right or top left

h2BSE R S5 -
: W Favorites :

[ro %
e ®

W Expression

1A
v
jj

o

g

Example 3 - Enter an Expression Using Palettes

Review the following example:
10

> (7 £ —5i) = 2420

i=1

10

In this example, we will enter Z (7 -5 i) and evaluate the expression.

i=0

Action

Result in Document

1. Place the cursor in a new document block. In the Expression palette,

n

click the summation template =% . Maple inserts the summation
symbol with the range variable placeholder highlighted.

>
i=i

2. Enter i and then press Tab. The left endpoint placeholder is selected. s
Notice that the color of the range placeholder has changed to black. E f

Each placeholder must have an assigned value before you execute the

expression. The Tab key advances you through the placeholders of an| i = f

inserted palette item.

3. Enter 1 and then press Tab. The right endpoint placeholder is selected.

4. Enter 10 and then press Tab. The expression placeholder is selected. | 10
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Action Result in Document

5. Enter ( 72-5 i) . For instructions on entering this type of expression, 10
see Example 1 - Enter and Evaluate an Expression Using 2z :
7 i 5
Keystrokes (page 6).

i=1
6. Press Ctrl + = (Command + = for Macintosh) to evaluate the 10
summation. 2
Z (71 - 1):2420
i=1

Handwriting Palette

The Handwriting palette provides another way to find and insert desired symbols easily.
1. Draw the symbol with your mouse in the space provided.

T
2. Click the recognize button, =

See Figure 1.3.

|. Maple matches your input against symbols available in the system.

3. To view more symbols (where indicated with a box around the result), click the displayed symbol and choose one
of the selections from the drop-down menu.

4. To insert a symbol, click the displayed symbol.

W Handwriting

| Input Window... |

Figure 1.3: Handwriting Palette
For more information, refer to the handwritingpalette help page.

Snippets Palettes

You can create your own custom Snippets palettes for tasks that you find most useful. Details on how to create and
customize Snippets palettes can be found on the createpalette help page.

Symbol Names

Each symbol has a name and some have aliases. By entering its name (or an alias) in Math mode, you can insert the

symbol in your document. All common mathematical symbols, including all Greek characters, &, and the square root
symbol (\/_ ), are recognized by Maple.

Note: If you hover the mouse pointer over a palette item, a tooltip displays the symbol's name.
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To insert a symbol, enter the first few characters of a symbol name using a keyword that is familiar to you and then
press the completion shortcut key, Esc (see Shortcut Keys by Platform (page xiii)). Symbol completion works in the
same way as command completion (see Command Completion (page 39)).

 Ifaunique symbol name matches the characters entered, Maple inserts the corresponding symbol.

 If multiple symbol names match the characters entered, Maple displays the completion list, which lists all matches,
including commands. To select an item, click its name or symbol.

Example 4 - Square Root

To find the square root of 603729:

Action Result in Document

1. In a new document block, enter sqrt. sqrf]

2. Press the symbol completion shortcut key, Esc. Maple | |
displays a popup list of exact matches.
sqrk ot
< [»

3. In the completion list, select . Jr

Maple inserts the symbol with the X placeholder selected.

4. Enter 603729 into the placeholder. /603729

5. Press Ctrl + = (Command + =, Macintosh).

603729 =777

Example 5 - Complex Numbers

When you simply type the letter 7 in Math mode, it is in italics. This letter is just a variable, and is not the same as the

imaginary unit / -1, denoted by I or i in Maple.

Multiply two complex numbers, -0.123 + 0.7451 and 4.2 —i:

Action Result in Document

1. In a new document block, enter (—0.123 + 0.745
(-0.123 + 0.745 1.

2. Press the symbol completion shortcut key, Esc. (~0.123 + 0.745 3f

Maple displays a popup list of partial and exact i (imaginary) e~
matches, including symbols and commands. lacute il
ic i
icir i
icontent feonfent(p)
icontent icontent
icosahedron (ocation) ploffools [Icosahedron ][ [x, 0, 2])
icosahedron location, scale)  ploffosls [icosahedron 1( 1,1, 21 1) ,v
<l 2]

3. Select the imaginary unit, [l (-0.123 + 0,745 ll

4. Close the parentheses, enter a space (for implicit (-0.123 +0.7451) (4.2 —1i)
multiplication), and type the second expression in
parentheses, using symbol completion for the
second imaginary number.

5. Press Ctrl + = (Command + =, Macintosh) to | (-0.123 + 0.7451) (4.2 — i) = 0.2284 + 3.25201
evaluate the product.
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For more information on entering complex numbers, refer to the HowDol/Enter AComplexNumber help page.

Toolbar Icons

In the introduction section, you learned about the toolbar icons and context toolbars available in Maple (see Toolbar
Options (page 7)). The toolbar can be used to format your document, alter plots and animations, draw in a canvas,
write in both Math and Text modes in one line and much more. The last of these is demonstrated in the next example.

Example 6 - Enter Text and 2-D Math in the Same Line Using Toolbar Icons
Enter the following sentence:

Evaluate

5
J (3 X +2 ﬁ + 3%/;) dx and write in simplest terms.

1
Action Result in Document
To enter this sentence: ey
1. Select the Text icon and enter "Evaluate ". |:E Text
> Evaluate|
2. Select the Math icon. e Drawint
3. From the Calculus palette, select the definite integration [ C 2 math -]
.'._‘ v x-l
[ ) i
i o . Eva.luatej fdx
template, . The expression is displayed with the m
first placeholder highlighted. JEaN
4. With the first placeholder highlighted, enter 1, then press | [=7] 5
Tab. ‘ Evaluatej 3 +2|dx
5. Enter 5 and press Tab to highlight the integrand region. L L
6. Enter (3x”2 and press the right arrow to leave the
superscript position.
7. Enter + 2.

8. Press the Space bar for implicit multiplication. Enter sqrt |V 3
and press Esc to show the command completion options. Evaluate r [ 3¢ +2 sqrt dx
Maple displays a popup list of exact matches. Select the

squarroot symbol, \/; . Sfrt st -

Maple inserts the symbol with the x placeholder selected. |-

(Alternatively, select the square root symbol from the

Expression palette.)
9. Enter x, then press the right arrow to leave the square root | [+ 3

region. Evaluatej 3242 Jx +3 EJT dx
10. Enter + 3, and then press the Space bar. Lo 1

11. Select the n-th root symbol from the Expression palette,

n\f?.
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Action Result in Document
12. Enter 3, then press Tab. ]

3
3
13. Enter x, then press the right arrow to leave the root region. Al Evaluate L 32 +3 Vx +3Vx d
14. Enter ), then press Tab.

15. Enter x for the integration variable.

16. Hover of the expression and click the circular popup to

3 "
toggle to nonexecutable math. (Alternatively, click the I (3 “ 42 Jx + 33 Vx ) df I/\\s
expression and use the shortcut Shift + F5.) 1

[Shift+F5 Toggle Executable Math |

17. Put the cursor after the expression and click the Text icon

Math Drawing Plot Animation
in the toolbar, then enter the rest of the sentence: " and

write in simplest terms." '::_ C Text V;:' '::_Times IHew Roman V;:' '::_ 12 '_;:' B I U
~ 5 I
Evaluate'[ (3 P Jr + 3= ) dx and write it simplest terms.
pay 1

Note: When an expression is intended for display purposes only, it can be made nonexecutable.

1.4 Point-and-Click Interaction

Maple contains many built-in features that allow you to solve problems quickly without having to know any commands.

Assistants

Maple offers a set of assistants in the form of graphical user interfaces to perform many tasks without the need to use
any syntax. An example of an assistant is shown in Figure 1.4.

Optimization Assistant
Sabver Probdsm
(2 Local Defauk: Cbjective Function
5
X p-y
(O Nonlrsar
Constrainks and Bourds
[x e [0,5]
ye [0,5)
Oiptions Y+y<6
() Minimize (%) Maimize
Frasiiity Tolerance def auk

N N

Chjecrive valus: 134.491161539748162

: UL el x = 4,535559292539129
Fberaticn Limit def ok ¥y = 1.46440707460871
Infinite Bound deFault

Figure 1.4: Optimization Assistant
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Using the Tools — Assistants menu, you can access tools to help you accomplish various tasks. See Figure 1.5. In
some cases, you can launch an assistant by entering an expression and selecting the assistant from the context menu
that displays.

Window Help

Assistants r Back-Solver...
Math Apps CAD Link...
Tutors L Code Generation... I
Tasks L Curve Fitting... I
Data Set Search...
Load Package L
Data Analysis... r
Unload Package L
eBook Publisher...
Spellcheck... Fi Equation Manipulator...
Complete Cornmand  Ctrl+5pace Import Data...
Help Database ! Installer Builder...
e Library Browser...
Maplet Builder...
ODE Analyzer...
Optimizaticn...
Plot Builder...

Scientific Constants...

Special Functions...

Thermophysical Properties Calculator...
Units Calculataor...

Worksheet Migration...

Figure 1.5: Accessing the Assistants from the Tools Menu
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Example 7 - Curve Fitting Assistant

Enter a data sample and use the Curve Fitting Assistant to find the best approximation of a function to fit the data.

Action Result in Document

1. From the Tools menu, select Assistants — Curve Fitting.
The first dialog in the Curve Fitting Assistant appears. M| Curve Fitting Assistant @

Enter data points below

Independent Values (x) Dependent Values (f{x]))

Current Page (1 Previous Page Mext Page

[ Fit H Clear H Import J I Help H Cancel I

2. Enter data as Independent Values and Dependent Values.
Alternatively, you could import a file containing data. If you M Curve Fitting Assistant =]
have more data than the space provided, click the Next Page
button for more space. For this example, enter the data as
shown.

Enter data points below
Independent Values (x) Dependent Values (f(x))
-1 -0.176777

-0.0494194

a

-0.44194

-0.176777

-0,397743

-0.707107

-1,104854

L= BT, R - i FC R R =]

Current Page (1 Previous Page Mext Page

[ Fit H Clear H Import J I Help H Cancel I

CurveFitting[ Interactive]();
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Action Result in Document
3. Once you have entered the data, click the Fit button. The | (cmerung s =
second dialog of the Curve Fitting Assistant appears.
1 1 2 3 k) 3 [
o, fe) Horizontal range: |-27/20 127/0 | Default
’ Verrorge: 09570 .. -1 et
04 [e]
[e]
Polynomial Interpolation
06 Plot.
] Spines
ne Degree of the spline: U Plot.
o]
-1 Least Squares
o Enter an expressionin x: 3" +b Plot
Done EditPoints | On Done'retun Inerpolant Help. Cancel
4. In this dialog, you can plot the data and several types of B Curv g At =]

interpolations, including Polynomial, Spline, and Least |
Squares. For example, click the Plot button in the
Polynomial Interpolation section. The polynomial is plotted
with the data, and the interpolating function is displayed
below.

Horizontal range: -27/20 127/20 Default
—
Vertical range: 3096700 .. J000e-1 | Default

Folynomial Interpolation

Plot

Splines

Degree of the spline

Flot
8

Least Squares

Enter an expressioninx: |a® +b Plot

]

-\2762122808e-2"% 7+ 45718209571 "6-, 3259304755 x5 +894927699 1 4 665671371 "3- 9888404085 ™" 2+, 082752470 "x-, 441941

Done Editponts | On ‘Done retun [{Srpoant + Help Cancel

5. You can choose to return either the interpolating function

or the plot to your document. When finished, click Done.

Descriptions of Assistants

The available assistants are described below. Some of the assistants are interfaces to package commands. For more
information on package commands, see Package Commands (page 38).

Back-Solver - an interface that allows you to take a mathematical formula, involving multiple parameters, enter
values for all but one of the parameters and solve for the remaining value. You can also plot the behavior of the
formula as one of the parameters change.

CAD Link - an interface to explore the properties of models from supported CAD applications (available on Microsoft
Windows only).

Code Generation- an interface to automatically transform Maple expressions and programs to other languages.

Curve Fitting - an interface to commands in the CurveFitting package. Data points can be entered as independent
and dependent values, and interpolated with polynomials, rational functions, or splines.

Data Set Search- an interface for searching built-in and online data sources.
Data Analysis - an interface to the data analysis commands in the Statistics package.
eBook Publisher- an interface to the eBook Publisher tools.

Equation Manipulator - an interface for interactively performing a sequence of operations on an equation. You
can group terms, apply an operation to both sides of the equation, complete the square, and so on.

Import Data - an interface to read data from an external file into Maple.
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Installer Builder - an interface to the InstallerBuilder package in which you can create installers for your Maple
toolboxes.

Library Browser - an interface to manipulate the libraries in a specified directory.

Maplet Builder - an interface to the Maplets package. The Maplets package contains commands for creating and
displaying Maplet applications (point-and-click interfaces). Using the Maplet Builder, you can define the layout of
a Maplet, drag-and-drop elements (visual and functional components of Maplets), set actions associated with elements,
and directly run a Maplet application. The Maplet Builder is available in the Standard interface only.

ODE Analyzer - an interface to obtain numeric or symbolic solutions to a single ordinary differential equation
(ODE) or a system of ODEs and plot a solution of the result.

Optimization - an interface to the solver commands in the Optimization package. The Optimization package is a
collection of commands for numerically solving optimization problems, which involves finding the minimum or
maximum of an objective function possibly subject to constraints.

Plot Builder - an interface for creating two and three-dimensional plots, animations, and interactive plots.

Scientific Constants - an interface to over 20 000 values of physical constants and properties of chemical elements.
All of these constants come with the corresponding unit and, if applicable, with the uncertainty or error, that is, how
precisely the value of this constant is known.

Special Functions - an interface to the properties of over 200 special functions, including the Hypergeometric,
Bessel, Mathieu, Heun and Legendre families of functions.

Units Calculator - an interface to convert between 500 units of measurement.

Worksheet Migration - an interface to convert worksheets from Classic Maple (.mws files) to Standard Maple
(.mw files).

Tutors

Maple provides over 50 interactive tutors to aid in the learning of

Precalculus

Calculus

Multivariate Calculus
Vector Calculus
Differential Equations
Linear Algebra
Numerical Analysis

Complex Variables

These tutors are easily accessible in the Tools menu by selecting Tutors. See Figure 1.6.
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Window Help

Aszcistants
Math Apps
Tutors

Taszks

Load Package
Unload Package

Spellcheck...

Complete Cornmand  Ctrl+5pace

Help Database
Options...

Check for Updates...

F7

o [B®x @

l
[T
b
i
Il

>
a
il
=]
ol
5
%
%]
Ui
L=}
v

L4 Calculus - Multivariate

]

L Calculus - Single Variable *

Complex Variables
Differential Equations
Linear Algebra
Mumerical Analysis
Precalculus

! Statistics

Wector Calculus

Figure 1.6: Accessing Tutors from the Tools Menu

]

]

]

Eigenvector Plot... I}
Eigenvalues...
Eigenvectors...
Gauss-lordan Elimination...
Gaussian Elimination...
Linear System Plot...

Linear System Solving...
Linear Transform Plot...
Matrix Builder...

Matrix Inverse...

Some of the tutors can also be accessed through the Student package. The Differential Equations tutor, DE Plots, is
accessible through the DEtools package. For a definition of the term package, see Package Commands (page 38).

The Student package is a collection of subpackages designed to assist with the teaching and learning of standard un-
dergraduate mathematics. The subpackages contain many commands for displaying functions, computations, and the-
orems in various ways, and include support for stepping through important computations.

The interactive commands help you explore concepts and solve problems using a point-and-click interface. These
commands launch tutors that provide a graphical interface to some of the visualization and computation commands
described above. See Figure 1.7 for an example of one of the tutors.

For more information on the tutors and related resources for mathematics education, see Teaching and Learning with

Maple (page 150).
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alcuius - inrrerentiation Methods o~
%] Calculus 1 - Differentiation Method 3
File Edit Rule Definition Apply Rule  Understood Rules  Help
Enter a function
Funckion | 2%:x+cos(x))sindx) Variable | x
d [ cos(x) W]
dx sin(x) )
d d
By g cas(x) W
dx dx | sim(x) )
= d d [ cosi(x) ]
=2 [Ex] el 7] shows s
gy i ( costa) )
dx | sie(x)
%cos(x)] sini(x) -cos(x) [Esm(xﬂ
= o = [ Constant ][ Identity ]
iRX
: AR
-5in°x - cas(x) [—sz’n(x) _
= dx [ Sum ][ Cifference ]
szx [ Product ][ Quatient l
el 2
_g oy SSx-cosTx [ Power |[  chainkue |
.S‘mzx [ Integral ” Resrite l
[ Exponential ][ Makural Logarithm ]
| =trig= | <hyperbalic= _'v
-<arctrig> '.v_czarch\,fperbnliczb i
[ Undo ] [ Mext Skep ] [ All Skeps ] [ Close ]

Figure 1.7: Calculus - Single Variable — Differentiation Methods Tutor

Math Apps

Maple provides Math Apps that offer interactive, entertaining ways to explore mathematical concepts, ranging from
Precalculus to Physics to Economics. A guide to these demonstrations is accessible in the Tools menu by selecting
Math Apps.

Context Menus

A context menu is a dynamically generated menu of actions that are applicable for the region on which it is invoked.

Context menus allow you to perform calculations and manipulations on expressions without using Maple syntax. To

display a context menu, right-click an object, expression, or region. Context menus are available for many input regions,
including:

* expressions to perform calculations, manipulations, or plotting
* plot regions to apply plot options and manipulate the plot

* tables to modify the table properties

 palette regions to add or remove palettes and palette regions

* text regions to add annotations and format text

When performing calculations or manipulations on an expression, a self-documenting arrow or equal sign connects
the input and output, indicating the action that took place. See Figures 1.8 and 1.9 for two examples of context menus.
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@2+ 18380 2 "
Cut Ctrl+X
Copy Ctrl+C
Copy Special r
Paste Ctrl+V

MNumeric Formatting...

Units Formatting...

Explore
Apply a Command 0.5+
Assign to a Name
Coefficients L4
Collect L3
] L |
Differentiate 4

Evaluate at a Point

Expand 4 -0.54
Factor :
Integrate r
Limit
-1
Plots ' Cut Ctrl+X
Series 4
Simplify N Copy Ctrl+C _05 -1
Solve 4 Isolate Expression for 4 CDp)f Sp ecial 4 0
Complete Square ) Numerically Solve Paste Ctrl+V x
MNumerically Solve (w/complex)
Complex Maps ) X i 1
- | Mumerically Solve from point Reset view
Conversions | Obtain Selutions for 4 i
Solve Style L4 Line
Integer Functions ) X % %
Solve (explicit) Symbol } Point
Integral Transforms )
Language Conversicns ) Solve (general solution) Line ! Point and Line
Attt | Solve for Variable 3
LA Color P v Surface with Line
. . . . o1 [ Surf
Figure 1.8: Right-click the expression to see a menu of ransparency Hriace
applicable operations Glossiness ! Surface with Contour
Orientation [ Contour
Lighting ! Hidden
Axes L
Title L4

Scaling Constrained
Manipulator L4

Export L4

Figure 1.9: Right-click the plot to see a menu of plot options

Task Templates

Task templates help you perform specific tasks in Maple, such as:

» performing a mathematical computation such as solving an equation symbolically or numerically, or determining
the Taylor approximation of a function of one variable

* constructing a Maple object such as a function

« creating a document such as an application

Each task contains a description along with a collection of content that you can insert directly into your document.
Content consists of 2-D mathematics, commands, embedded components (for example, buttons), and plots. You specify
the parameters of your problem and then execute the commands in the document. See Figure 1.10 for an example of
a Task Template.
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[ @ Browse Tasks

=@ = ]

File Wiew

- Querview

| Algebra

+)- || Calculus - Differential

Bl || Caleulus - Integral

-- , Integration

é} . Approximate Integration

Approximate Definite Integral of a Function

Murneric Integration

-- . Methods of Integration
[ |, Applications
- || Series

[ |, Calculus - Multivariate

[ |, Caloulus - Vector

----- Convert Expression to Function
H- | Curve Fitting
tl-- | | Differential Equations
t- || Document Templates
H-  eBook Metadata
H- | Evaluating

H- ) Geometry

H- | Integers

H- |, Linear Algebra
H- |, Lists

H- | Maple T.A.

H- | Plots

H- || Paolynomials

H- | Statistics

H-- || Transformations

H- | Units, Constants, and Errors
H--| J User Tasks

ou O oy OO OO OO OO e O e O oy IO oy OO o OO OO O IO IO O

4
¥ [ Copy Task to Clipboard ] [ Insert Default Content ]

[ Insert Minimal Content ] [7] Insert into New Worksheet

|| Display task markers

Y Approximate Definite
Integral of a Function

Description

Approximate the definite integral of a
univariate function using a Riemann sum or
a Newton-Cotes method.

Enter the function as an expression.

2
>x +2
P42 (L
Specify the range of integration and the method

of approximation, and then approximate the
integral

> Student| Calculus 1| Approximatelnt|(
(). x=0_.2 7, method= trapezoid)

1 2
EE(IOE}+6?E} @

>

Alternatively, you can use the Approximate

Integrals tutor, a point-and-click interface.

There are two ways to launch this tutor.

* From the Tools menu, select Tutors,
Calculus - Single-Variable and then
Approximate Integrals.

1| i | 3

»

m

Task,ApproxDefIntegralUnivariateFcn

h

Figure 1.10: Browse Tasks Dialog

Previewing Tasks

To preview Maple tasks,

* From the Tools menu, select Tasks, and then Browse. The Browse Tasks dialog opens and displays the list of tasks.

The tasks are sorted by subject to help you quickly find the desired task. In the Browse Tasks dialog, you can view
tasks without inserting them into your document.

Inserting a Task into the Document
To insert a task into your document,
1. Select the Insert into New Worksheet check box to insert the task into a new document.

2. Click one of the insert buttons.
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* Click the Insert Default Content button. Maple inserts the default content. The default content level is set using
the Options dialog. For instructions, see the usingtasks help page.

* Click the Insert Minimal Content button. Maple inserts only the commands and embedded components, for example,
a button to launch the related assistant or tutor.

* Click the Copy Task to Clipboard button. Place the cursor where you want to insert the task, and then paste the
task. Maple inserts the default content. Use this method to quickly insert a task multiple times.

Note: You can view the history of previously inserted tasks. From the Tools menu, select Tasks. Previously selected
task names are displayed below the Browse menu item.

Before inserting a task, Maple checks whether the task variables have assigned values in your document. If any task
variable is assigned, the Task Variables dialog opens to allow you to modify the names. Maple uses the edited variable
names for all variable instances in the inserted task.

By default, the Task Variables dialog is displayed only if there is a naming conflict. You can set it to display every
time you insert a task.

To specify that the Task Variables dialog be displayed every time you insert a task:
1. From the Tools menu, select Options.

2. Click the Display tab.

3. In the Show task variables on insert drop-down list, select Always.

4. Click Apply to Session or Apply Globally, as necessary.

Updating Parameters and Executing the Commands

In inserted Task Templates, parameters are marked as placeholders (in purple text) or specified using sliders or other
embedded components.

1. Specify values for the parameters in placeholders or using graphical interface components. You can move to the
next placeholder by pressing Tab.

2. Execute all commands in the task by:

Placing the cursor in the first task command, and then pressing Enter repeatedly to execute each command.

Selecting all the template commands, and then clicking the execute toolbar icon [ .

3. If the template contains a button that computes the result, click it.

For more information on task templates, refer to the tasks help page.

Exploration Assistant

The Exploration Assistant allows you to interactively make parameter changes to expressions and view the result. The
assistant can be used with almost any Maple expression or command that has at least one variable or parameter.

To launch the Exploration Assistant:
1. Enter an expression or command.
2. Right-click (Control-click, Macintosh) the expression or command. From the context menu, select Explore.

3. The Explore parameter selection dialog appears, where you can select the parameters to explore and the range for
each parameter.

If you enter integer ranges, only integer values are allowed for parameters. To allow floating-point values, enter floating-
point ranges.

Select skip for any of the parameters to leave that parameter as a variable.
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4. Click Explore to continue to the Exploration Assistant. The assistant creates a table in the document . You can
use the slider or sliders to vary the parameters and see your changes as the expression output is updated.

5. Once you are finished interacting with the assistant, you can copy and paste the results into your document, or save
the interactive document for later use.

Example 8 - Use the Exploration Assistant to Explore a Plot

sin(a x) — bcos(x)
X

In this example, we will explore how the plot of changes as we vary the parameters a and b.

Action Result in Document

plot(

1. Enter the plot command shown. sin(a x) — bcos(x)

X

,x:l..loj

2. Right-click (Control-click for Macintosh)
the expression and select Explore.

_p.for[ sin{a-x) — b-cos(x) =1 "10]

X

Copy Special ]
Paste Chrl+Y

Evaluate and Display Inline Chrl+=

s

Explore

Apply a Command
Assign ko a MName

Conwversions ]

Language Conwersians ]

Help on Command

2-0 Math »
3. In the Explore parameter selection dialog, | B8 Explore = [
set the ranges a=0..10.0 and b =-5.0..5.0.
Parameter Controks
Basics Ovarrides
ship control walies placemernt animate
& ghder - q n default = default =
b sider - 5 . (@ default - default
Msc,
Defaits
s default
placement  un@sl - == MEVEl w
animate unset frames 50
NUMENc
refunn cammand | Expiore | Carvel
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Action Result in Document

4. Click Explore. The Exploration Assistant =
creates a table in the document. Move the 3
sliders to see the plot as the parameters - f ||
change. N || | ,‘ﬂ \ Y

| | Il. f '.I Jr\\ll

1.5 Commands

Even though Maple comes with many features to solve problems and manipulate results without entering any commands,
you may find that you prefer greater control and flexibility by using the set of commands and programming language

that Maple offers.

The Maple Library

Commands are contained in the Maple library, which is divided into two groups: the main library and packages.

The main library contains the most frequently used Maple commands.

Packages contain related commands for performing tasks from disciplines such as Student Calculus, Statistics, or
Differential Geometry. For example, the Optimization package contains commands for numerically solving optimiz-

ation problems.

For details on top-level and package commands, see Commands (page 63).

Entering Commands

If you want to interact with Maple using commands, simply enter the command using 2-D math. Notice that commands
and variable names display in italics. Maple commands are constructed in a format similar to command(arguments),

based on the command you are using.

For example, to factor an expression, enter:

factor(x2 +2x+ 1)
(x+1)°

To differentiate an expression, enter:

diff(sin(x), x)
cos(x)
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To integrate an expression on the interval [0, 2 &t], enter:

int(2 x+ cos(x),x=0.2x)

To plot an expression, enter:
plot(sin(x) xz, x=-10 ..10)

60

40

-1 5 0 5 0

_20_

_40_

-60 4

For a list of the top commands in Maple, see Top Commands (page 64).

Package Commands

There are two ways to access commands within a package, using the long form of the package command or the short
form.

Long Form of Accessing Package Commands:

The long form specifies both the package and command names using the syntax package[command](arguments).
LinearAlgebral RandomMatrix] (2)

44 -31
92 67

Short Form of Accessing Package Commands:

The short form makes all of the commands in the package available using the with command, with(package). If you
are using a number of commands in a package, loading the entire package is recommended. When you execute the
with command, a list of all commands in the package displays. To suppress the display of all command names, end
the with(package) command with a colon. Alternatively, you can load packages through the Tools menu, by selecting
Load Package, and then the package name.
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with( Optimization)
[ ImportMPS, Interactive, LPSolve, LSSolve, Maximize, Minimize, NLPSolve, QPSolve]

After loading a package, you can use the short-form names, that is, the command names, without the package name.

LSSolve([x—2,x—6,x—9])
[12.3333333333333321, [x=5.66666666666667] ]

For a list of the top packages in Maple, see Top Packages (page 66).

Command Completion

To help with syntax and reduce the amount of typing when entering Maple commands, you can use command completion.
Command completion displays a list of all Maple packages, commands, and functions that match the entered text. If
there are multiple ways to call a command, then the command completion list contains each one, with appropriate
placeholders.

To use command completion:

1. Begin entering a command or package name.

2. Select Tools — Complete Command or use the shortcut key Esc (see Shortcut Keys by Platform (page xiii)). If
there is a unique completion, it is inserted. Otherwise, a list of possible matches is displayed.

3. Select the correct completion from the list.

Linear

Linearalgebra 3 (fadl
LinearalgebralAdd] (linear combinatian) LinearAlgebra [ Add | Mvl, Mv2)
Lineatalgebra(Add] (inear combination, with scalars and constructar opkions) LinearAlgebra [Add (v, v2, xI, x2
LinearalgebralAdd] (linear combinatian, with scalars) Lingardigebra | Add | (Mo I, Mul, xi, x2)
Lineatalgebra(Add] (inear combination, with scalars, construckor options, and owverwrite) LinearAlgebra| Add v
Linearalgebral Adjoint] {square Makrix) LinearAlgebra| Adicint 1M )
LineatalgebraAdjoint ] (square Matrix, with constructor opkions) LinearAlgebra | Adioing || M, oufputopfions = st
Linearalgebra[BackwardSubstituke] (upper row-echelon) LinearAlgebra |BaciwardSubstfufa |( 1)
Linearalgebra[BackwardSubstituke] (upper row-echelon) LinearAlgebra | BaciwardSuhstfuda | M, Mv)
Linearalgebra[BackwardSubstitute] (upper row-echelon, with options and overwrite) LinearAlgebra|BackwardSu
Linearalgebra[BackwardSubstitute] (upper raw-echelon, with options) LinearAlgebra | BackwardSubsifute |1 3, v,
!i{nﬁar.ﬂlnﬁhral’ﬁandl\ﬂarriﬂ (Fram aralarst Timaardicahral Rand fapir i 17 v2 .l.>1. i

4. Some inserted commands have placeholders, denoted by purple text. The first placeholder is highlighted after you
insert it into the document. Replace it with your parameter, then move to the next placeholder by pressing the Tab
key.

Equation Labels
Equation labels help to save time entering expressions by referencing Maple output. See Figure 1.11.

By default, equation labels are displayed. If equation labels are not displayed,

1. From the Tools menu, select Options, and click the Display tab. Ensure that the Show equation labels check box
is selected.

2. From the Format menu, select Equation Labels. Ensure that both Execution Group and Worksheet are selected.
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] '\‘sin(x) i ]

% —cos(x) I
—sm(x) (5]

[

Figure 1.11: Equation Label

To apply equation labels:

1. Enter an expression and press Enter. Note that the equation label is displayed to the right of the answer in the doc-
ument.

2. In a new execution group, enter another expression that will reference the output of the previous execution group.

3. From the Insert menu, select Label. Alternatively, press Ctrl+L (Command+L, for Macintosh) to open the Insert
Label dialog. Enter the label number in the Insert Label dialog and click OK. The item is now a label. See
Figure 1.12.

‘sin(x) dr ]
% ) - cos(x) (L)
N ‘ fdx

Insert Label
Type: Equation v
Identifier: |1
I OF l [ Cancel

Figure 1.12: Inserting an Equation Label

4. Press Enter to obtain the result.

To change the format of equation labels:

* Select Format — Equation Labels — Label Display. In the Format Labels dialog, select one of the numbering
schemes.

» Optionally, enter an appropriate numbering prefix.
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b T
sin(x) dx ct
A —cos(x) {(Answerl)
]
[(Answerl) dx
e
—sm(x) (Answerl)
Format Labels
Label Mumbering Prefiz | Answer|
Label Mumbering Scheme | Flat Mumeric w
[ oK ] [ Cancel

Figure 1.13: Format Labels Dialog: Adding a Prefix

The Label Reference menu item allows you to switch between the label name and its reference content. Place the
cursor on the referenced equation label and select Format — Equation Labels — Label Reference.

~ IFE A
- —cos(x) I

)
Z _[—cns(x) dx

—sm(x) (4]

Figure 1.14: Label Reference

The label is associated with the last output within an execution group.

You cannot apply equation labels to the following:
* Error, warning, and information messages

 Tables, images, plots, or sketches

Document Blocks

In Document mode, content is created as a series of document blocks. Document blocks allow you to hide the syntax
used to perform calculations, which in turn lets you focus on the concept presented instead of the command used to
manipulate or solve the problem. You can also create document blocks in Worksheet mode to perform the same function.
Document blocks are typically collapsed to hide the Maple code, but these regions can also be expanded to reveal this
code.

To create a document block:

From the Format menu, select Create Document Block. If text or math in one or more execution groups is selected,
then a document block is created that contains those execution groups. If not, a new document block is created after
the current execution group. For more information, see the next example.

Document block regions are identified using markers that are located in a vertical bar along the left pane of the document.
See Figure 1.15. In addition to document block boundaries, these markers (icons) indicate the presence of hidden at-
tributes in the document such as annotations, bookmarks, and numeric formatting.
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To activate markers:

From the View menu, select Markers. See Figure 1.15.

L C 20math * | | Times Iew Roman ) (12

Fee ¥ .
X2+ 10x+ 21 25 fx=—3), {x=—7)

Figure 1.15: Document Block Markers

To view code in a document block:
1. Place the cursor in a document block to be expanded.

2. From the View menu, select Expand Document Block.

‘ k G 20 math ¥ | | Times [Mew Roman .20 e '.J.' B H

v[} 4+ 10x+ 21

2 L0 B L

)

Figure 1.16: Expanded Document Block

With the Document Block expanded, you can see the Maple command that was used to perform this calculation. In
Figure 1.16, the solve command was used.

Also notice a red prompt (>) before the original expression and the solve command. Entering commands outside of a
document block region is done at this input region. To insert an input region, click the [> button in the toolbar menu.

In Figure 1.16, an equation label was used to refer to the expression. For more information, see Equation
Labels (page 39).

To collapse a Document Block:

* With your cursor inside the document block, select View — Collapse Document Block.

You can use this process of expanding document blocks to view and edit Maple commands within a document block.
Changing the Display:

You can specify which parts of the input and output are displayed when the document block is collapsed. For each
execution group in the block, you can choose to display either the input or the output.
* Place the cursor in the execution group.

* From the View menu, select Toggle Input/Output Display.

Also, you can choose to display output either inline or centered on a new line.

* From the View menu, select Inline Document Qutput.
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1.6 The Maple Help System

The Maple program provides a custom help system consisting of almost 5000 reference pages. The help system is a
convenient resource for determining the syntax of Maple commands and for learning about Maple features.

Accessing the Help System

There are several ways to access the Maple help system:
* From the Help menu, select Maple Help.
» Enter a search term in the search box in the worksheet toolbar.

* Click (@) in the toolbar.

To get help on a specific word:

* In a document, place the insertion point in a word for which you want to obtain help. From the Help menu, select
Help on .... Alternatively, press F2 (Control + ?, for Macintosh) to access context-sensitive help.

* In a document, execute the command ?topic, for example, enter ?LinearAlgebra and press Enter.
The Maple help system opens in a separate window with two panes. The left pane contains the Help Navigator where

you initiate searches and browse the table of contents, and the right pane displays the final search result, such as a
specific help page.
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Figure 1.17: Sample Help Page

Every help page in Maple lists the command's calling sequence, parameters, and a description, with examples of the
command at the end of the page. Some help pages also contain hyperlinks to related help pages and hyperlinks to dic-
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tionary definitions. Hyperlinks to dictionary definitions display in red to distinguish them from hyperlinks to help
pages.

Using the Help Navigator

Use the search field in the Help Navigator to find information on Maple commands and features.

* Search for a known help topic, a command name, or a keyword or phrase.

 If you have any add-on products, you can restrict the search to Maple, MapleSim, or any combination of those
products and their add-ons.

* You can search all of the help system or specific Resources such as Help Pages, Tasks, Math Apps, and Manuals
by selecting the Page Types drop-down menu.

Search results are displayed as a list in the Search Results tab of the left pane. Click the Table of Contents tab to
view a structured list of all topics in the help system.

Note that some tutorials open in a Maple window instead of in the Help window.
In the left pane, the type of resource is indicated by an icon. Table 1.9 describes the icons.

Table 1.9: Help Page Icons

Icon Description

A folder icon in the Table of Contents tab indicates that a topic can be expanded into subtopics.

Question mark icon indicates a help page and displays the associated help page in the right pane when selected.

WS icon indicates an example worksheet. Example worksheets open in a new tab in the Maple document.

D icon indicates a definition and displays the associated dictionary definition in the right pane when selected.

T icon indicates a Task template and displays the associated Task Template in the right pane when selected.

M icon indicates a manual. Manuals open in a new tab in the Maple document.

=== |# =L

Viewing Help Pages as Documents
In the help system, examples are not executable.
The Maple help system allows you to open help pages as documents that you can execute.

To open a help page as a worksheet:

» With the help page displayed in the right pane of the help system, from the View menu, select Open Page as
Worksheet. A new worksheet tab opens and displays the help page as an executable document.

& Alternatively, in the help system toolbar, click the open current help page in a worksheet window icon.

Viewing Examples in 2-D Math

You can choose to view the examples in most help pages in either 2-D math or 1-D Math (Maple input) mode. The
default is 2-D Math.
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To change the math mode:
In the Maple help system:
* From the View menu, select or clear the Display Examples with 2D math check box.

. . XA2
* Click the 2-D Math icon, L y 2.

Note: Some input in help pages displays as 1-D Math, no matter which option you have chosen. This is for Maple
procedures and other code that is best input in 1-D Math. For more information, see the helpnavigator help page.

Copying Examples

Instead of opening the entire page as a document, you can copy the Examples section only.

To copy examples:

1. With the help page displayed in the right pane of the help system, from the Edit menu, select Copy Examples.
2. Close or minimize the Help Navigator and return to your document.

3. In your document, place the cursor at the location where you want to paste the examples.

4. From the Edit menu, select Paste. The Examples section of the help page is inserted as executable content in your
document.

1.7 Available Resources

Your work with Maple is supported by numerous resources.
Resources Available through the Maple Help System

Help Pages

Use the help system to find information about a specific topic, command, package, or feature. For more information,
see The Maple Help System (page 43).

Dictionary

More than 5000 mathematical and engineering terms with over 300 figures and plots.

1. From the Help menu, select Maple Help.

2. Enter a search term. Dictionary entries that match your query are displayed in the left pane with a (o] icon.

Tutorials and the Maple Portal

The Maple Portal includes material designed for all Maple users, from new users to users who want more advanced
tutorials. The Maple Portal also includes specific sections for students, math educators, and engineers. The Maple
Portal includes:

* How Do I... topics that give quick answers to essential questions.

 Tutorials that provide an overview of topics from getting started to plotting, data manipulation, and interactive ap-
plication development.

» Navigation to portals with specialized information for students, math educators, and engineers.

Access the portal in the Table of Contents under Getting Started.
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Applications and Example Worksheets
Applications

Sample applications demonstrate how Maple can be used to find and document a solution to a specific problem. Some
applications allow for input or contain animations that you can run; however, their primary use is for demonstrations.
Topics include Bouncing Ball, Digital Filter Design, Frequency Domain System Identification, Harmonic Oscillator,
Image Processing, Radiator Design with CAD Systems, and Sunspot Periodicity.

Examples

Example worksheets are executable documents covering topics that demonstrate syntax or invoke a user interface to
make complex problems easy to solve and visualize. You can copy and modify the examples as needed. Topics include
Algebra, Calculus, Connectivity, Discrete Mathematics, General Numerics and Symbolics, and Integral Transforms.

» Explore the available topics in the Table of Contents under Applications and Example Worksheets.
Manuals

You can access all of Maple's manuals from within Maple, including the Maple Programming Guide and this manual.
You can execute examples, copy content into other documents, and search the contents using the Maple Help System.

¢ Access the manuals in the Table of Contents under Manuals.

Maple's manuals are also available as PDFs on the Maplesoft web site.

http://www.maplesoft.com/documentation_center

Task Templates

Set of commands with placeholders that you can use to quickly perform a task. For details, see Task Templates (page 33).
¢ From the Tools menu, select Tasks, and then Browse.

Maple Tour and Quick Resources

Maple Tour

The Maple Tour consists of interactive sessions on several of the following topics: Ten Minute Tour, Numeric and
Symbolic Computations, Matrix Computations, Differential Equations, Statistics, Programming and Code Generation,

Units and Tolerances, and Education Assessment with Maple TA™

* From the Help menu, select Take a Tour of Maple.

Quick Help and Quick References

The Quick Help dialog is a list of key commands and concepts.

* From the Help menu, select Quick Help. Alternatively, press F1. For additional information, click an item in the
Quick Help.

The Quick Reference is a table of commands and information for new users that opens in a new window. It contains
hyperlinks to help pages for more information.

* From the Help menu, select Quick Reference. Alternatively, press Ctrl + F2 (Command + F2, for Macintosh).


http://www.maplesoft.com/documentation_center
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Web Site Resources

Welcome Center

A Maple web site offering all of Maplesoft's key user resources in one central location. In the Welcome Center, you
can view sample applications, participate in user forums, and access premium content. You can also access our support
services, view training videos, download user manuals, and more.

http://www.maplesoft.com/welcome
Student Help Center

The Student Help Center offers a Maple student forum, online math Oracles, training videos, and a math homework
resource guide.

http://www.maplesoft.com/studentcenter
Teacher Resource Center

The Teacher Resource Center is designed to ensure you get the most out of your Maple teaching experience. It provides
sample applications, course material, training videos, white papers, and tips.

http://www.maplesoft.com/TeacherResource
Application Center

Maple web site resource for free applications related to mathematics, education, science, engineering, computer science,
statistics and data analysis, finance, communications, and graphics. Many applications are available in translations
(French, Spanish, and German).

http://www.maplesoft.com/applications
Training

Maplesoft offers a comprehensive set of complementary training materials. From complete training videos to recorded
training seminars to downloadable documentation, you have many options to get familiar with Maplesoft products. In
addition, custom training sessions can be created to meet your needs.

http://www.maplesoft.com/support/training
MaplePrimes

A web community dedicated to sharing experiences, techniques, and opinions about Maple and related products, as
well as general interest topics in math and computing.

http://www.mapleprimes.com

Online Help

All of Maple's help pages are available online.
http://www.maplesoft.com/support/help
Technical Support

A Maple web site containing FAQs, downloads and service packs, links to discussion groups, and a form for requesting
technical support.

http://www.maplesoft.com/support


http://www.maplesoft.com/welcome
http://www.maplesoft.com/studentcenter
http://www.maplesoft.com/TeacherResource
http://www.maplesoft.com/applications
http://www.maplesoft.com/support/training
http://www.mapleprimes.com
http://www.maplesoft.com/support/help
http://www.maplesoft.com/support
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For a complete list of resources, refer to the MapleResources help page.



2 Document Mode

Using the Maple software, you can create powerful interactive documents. You can visualize and animate problems
in two and three dimensions. You can solve complex problems with simple point-and-click interfaces or easy-to-
modify interactive documents. You can also devise custom solutions using the Maple programming language. While
you work, you can document your process, providing text descriptions.

2.1 In This Chapter

Section Topics

Introduction (page 49) * Comparison of Document and Worksheet Modes

Entering Expressions (page 50) - Overview of tools for creating |* Palettes

complex mathematical expressions « Symbol Names

¢ Mathematical Functions

Evaluating Expressions (page 52) - How to evaluate expressions |* Displaying the Value Inline

 Displaying the Value on the Following Line

Editing Expressions and Updating Output (page 53) - How to  |* Updating a Single Computation

update expressions and regenerate results + Updating a Group of Computations

» Updating All Computations in a Document

Performing Computations (page 53)- Overview of tools for * Computing with Palettes

performing computations and solving problems « Context Menus

¢ Assistants and Tutors

2.2 Introduction

Maple has two modes: Document mode and Worksheet mode.

Document mode is designed for quickly performing calculations. You can enter a mathematical expression, and then
evaluate, manipulate, solve, or plot it with a few keystrokes or mouse clicks. This chapter provides an overview of
Document mode.

Document mode sample:

Find the value of the derivative of 11’1( X+ 1) at x=4.

1 n( v 1) differentiate wr.t.x 2 x  evaluate atpoint 8
X +1 17

Integrate Sin[ij over the interval [0, r].

ol ) s )= 2)

0

Worksheet mode is designed for interactive use through commands and programming using the Maple language. The
Worksheet mode supports the features available in Document mode described in this chapter. For information on using
Worksheet mode, see Chapter 3, Worksheet Mode (page 61). Note: To enter a Maple input prompt while in Document

mode, click [ in the Maple toolbar.

49
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Important: In any Maple document, you can use Document mode and Worksheet mode.

Interactive document features include:

» Embedded graphical interface components, like buttons, sliders, and check boxes
* Automatic execution of marked regions when a file is opened

 Tables

 Character and paragraph formatting styles

* Hyperlinks
These features are described in Chapter 7, Creating Mathematical Documents (page 221).

Note: This chapter and Chapter 1 were created using Document mode. All of the other chapters were created using
Worksheet mode.

2.3 Entering Expressions

Chapter 1 provided an introduction to entering simple expressions in 2-D Math (see Entering Expressions (page 16)).
It is also easy to enter mathematical expressions, such as:

-x x<0
* Piecewise-continuous functions: [X =7 0 x=0
X 0<x
 Limits: 8(x) = limoe|x|6 -1
€ —
. . 1
+ Continued fractions: 2 =1 + 1
2 + ]
2 +
2+ -

and more complex expressions.
Mathematical expressions can contain the following objects.

* Numbers: integers, rational numbers, complex numbers, floating-point values, finite field elements, 1, o, ...

0
. . - ' . 1 _
Operators: +, -, |, /, ,J, tha’ ax

¢ Constants: m, e, ...

], r(2), ..

« Mathematical functions: sin(x), COS[%
* Names (variables): X, ¥, Z, o, B, ...

 Data structures: sets, lists, Arrays, Vectors, Matrices, ...

Maple contains over a thousand symbols. For some numbers, operators, and names, you can press the corresponding
key, for example, 9, =, >, or x. Most symbols are not available on the keyboard, but you can insert them easily using
two methods, palettes and symbol names.
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Example 1 - Enter a Partial Derivative

To insert a symbol, you can use palettes or symbol names.

0 -
Enter the partial derivative &e

using palettes.

Action

Result in Document

1. In the Calculus palette, click the partial

d
a _
differentiation item gy ! . Maple inserts the partial dx
derivative. The variable placeholder is selected.
2. Enter t, and then press Tab. The expression a
placeholder is selected. — 1
at
- : 2
3. Enter € = . Note: To enter the exponential e, use 0 -t
the expression palette or command completion. ait S

To evaluate the derivative and display the result inline, press Ctrl+= (Command+=, for Macintosh) or Enter. For

more information, see Computing with Palettes (page 53).

You can enter any expression using symbol names and the symbol completion list.

Action

Result in Document

1. Begin typing the name of the symbol,
diff, and press the symbol completion
key (see Shortcut Keys by
Platform (page xiii)).

dif

diff (inline)

diff@a@

diffalg

<

diff (inline partial)

diff _table (Function and derivatives)
diff_table (representation of function and derivatives)  DETools [diff table |(expr |

diffop2de (differential operator)

diffigE

PDFfools [diff tabie |(expr)

diffaly

DETools [diffop2de 1(oper, p) ¥ |
>

2. Select the partial differentiation item,

a ox
diff {inline partial) W
3. Replace the placeholder with t. Use the )
right arrow to move out of the o -t
denominator. Enter €~ as in the ot

previous example.

2re @n

Example 2 - Define a Mathematical Function

Define the function twice, which doubles its input.

Action

Result in Document

1. In the Expression palette, click the single variable

function definition item, f=a—y

f=a—y

2. Replace the placeholder f with the function name,

twice. Press Tab to move to the next placeholder.

twicg =@ — ¥
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Action Result in Document

3. Replace the parameter placeholder, a, with the twice == x — §

independent variable X. Press Tab.

4. Replace the output placeholder, y, with the desired | fyjce .= x — 2 x
output, 2 X.

xX—2 X

twice(1342) = 2684
twice(y—z)=2y—2z

Note: To insert the right arrow symbol — , you can also enter the characters -> in Math mode. In this case, symbol
completion is automatic.

Important: The expression 2 X is different from the function x — 2 X.

For more information on functions, see Functional Operators (page 268).

2.4 Evaluating Expressions

To evaluate a mathematical expression, place the cursor in the expression and press Ctrl + = (Command + =, for
Macintosh). That is, press and hold the Ctrl (or Command) key, and then press the equal sign (=) key.

To the right of the expression, Maple inserts an equal sign and then the value of the expression.

L7 8

2 -
9 11 99

In mathematical content, pressing Enter evaluates the expression and displays it centered on the following line. The
cursor moves to a new line below the output.

2 7
9+11
85

2.2
99 22)

By default, Maple labels output that is generated by pressing Enter. For information on equation labels, see Equation
Labels (page 74). In this manual, labels are generally not displayed.

In text, pressing Enter inserts a line break.

You can use the basic algebraic operators, such as + and — , with most expressions, including polynomials—see
Polynomial Algebra (page 114)—and matrices and vectors—see Matrix Arithmetic (page 127).

(28 —x+1) = (¥ +2x+12) =¥ -3x-11

-12 24 297
81 207 87

-4 8 99
27 69 29
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2.5 Editing Expressions and Updating Output

One important feature of Maple is that your documents are /ive. That is, you can edit expressions and quickly recalculate
results.

To update one computation:
1. Edit the expression.

2. Press Ctrl + = (Command + =, for Macintosh) or Enter.
The result is updated.

To update a group of computations:
1. Edit the expressions.

2. Select all edited expressions and the results to recalculate.

3. Click the Execute toolbar icon =
All selected results are updated.

To update all output in a Maple document:

* Click the Execute All toolbar icon
All results in the document are updated.

Note: Be careful when you revisit a document and make changes, as it's possible to produce a document with worksheet
commands out of order (i.e. where a certain command won't work properly without a later one).

2.6 Performing Computations

Using the Document mode, you can access the power of the advanced Maple mathematical engine without learning
Maple syntax. In addition to solving problems, you can also easily plot expressions.

The primary tools for syntax-free computation are:
 Palettes
» Context menus

e Assistants and tutors

Note: The Document mode is designed for quick calculations, but it also supports Maple commands. For information
on commands, see Commands (page 63) in Chapter 3, Worksheet Mode (page 61).

Important: In Document mode, you can execute a statement on/y if you enter it in Math mode. To use a Maple command,
you must enter it in Math mode.

Computing with Palettes
As discussed in Entering Expressions (page 50), some palettes contain mathematical operations.

To perform a computation using a palette mathematical operation:
1. In a palette that contains operators, such as the Expression or Calculus palettes, click an operator item.
2. In the inserted item, specify values in the placeholders.

3. To execute the operation and display the result, press Ctrl+= (Command+=, for Macintosh) or Enter.
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0 -
For example, to evaluate 676 e inline:

1. Using the Calculus palette, enter the partial derivative. See Example I - Enter a Partial Derivative (page 51).

2. Press Ctrl+= (Command+=, for Macintosh).

Context Menus

A context menu is a popup menu that lists the operations and actions you can perform on a particular expression. See
Figure 2.1.

2, 1

7 Cut Crl+X
Copy Ctrl+C
Copy Special L
Paste Ctrl+V
Explore

Apply a Command
Approximate L
Assign to a Name

Denominator

Mumerator
Plots 4
Integer Functions L
Units 4
2-D Math 4
Create Task

Figure 2.1: Context Menu

To display the context menu for an expression:

» Right-click (Control-click, for Macintosh) the expression.
The context menu is displayed beside the mouse pointer.

You can evaluate expressions using context menus. The Evaluate and Display Inline operation (see Figure 2.1) is
equivalent to pressing Ctrl+= (Command+=, for Macintosh). That is, it inserts an equal sign (=) and then the value
of the expression.

Alternatively, press Enter to evaluate the expression and display the result centered on the following line.
For more information on evaluation, see Evaluating Expressions (page 52).

From the context menu, you can also select operations different from evaluation. To the right of the expression, Maple
inserts a right arrow symbol (—) and then the result.
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t 10 digit
For example, use the Approximate operation to approximate a fraction: % O, 0.6666666667

You can perform a sequence of operations by repeatedly using context menus. For example, to compute the derivative

of COS( X ), use the Differentiate operation on the expression, and then to evaluate the result at a point, use the
Evaluate at a Point operation on the output and enter 10:

. . 1 .
COS(XZ) differentiate w.r.t. x o sin( XZ) X evaluate at point 20 sin(100)

Note: For the sequence of operations to make sense when being read from left to right, stale results are deleted before
new context menu operations are performed.

For example:

Enter the expression x°. ¥

Right-click on the expression and use the Differentiate option to 2 differentiate w.r.t. x

differentiate with respect to x. 2x

Right-click on 2x and use the Integrate option to integrate with 2 differentiate w.r.t. x 2y integrate w.r.t. x V:
respect to x.

Right-click on 2x again and use the Differentiate option to 2 differentiate w.r.t. x differentiate w.r.t. x
. . | 2x 2
differentiate with respect to x.

Notice how the result of integration with respect to x has been
replaced with the result of differentiation with respect to x so that
the sequence of operations makes sense.

The following subsections provide detailed instructions on performing a few of the numerous operations available using
context menus. Figures in the subsections show related context menus or palettes.

Approximating the Value of an Expression

To approximate a fraction numerically:
1. Enter a fraction.
2. Display the context menu. See Figure 2.2.

3. From the context menu, select Approximate, and then the number of significant digits to use: 5, 10, 20, 50, or 100.



56 + 2 Document Mode

2

3 Cut Ctrl+X
Copy Ctrl+C
Copy Special L
Paste Ctrl+V
Explore

Apply a Command

Approximate ’ 5
Assign to a Name 10
Denominator 20 Dv‘
Mumerator 50
Plots ' 100
Integer Functions L

Units L

2-D Math 4

Create Task

Figure 2.2: Approximating the Value of a Fraction

10 digi
% A8, ) 6666666667

You can replace the inserted right arrow with text or mathematical content.

To replace the right arrow ( — ):
1. Select the arrow and text. Press Delete.
2. Enter the replacement text or mathematical content.

Note: To replace the right arrow with text, you must first press F5 to switch to Text mode.

For example, you can replace the arrow with the text "is approximately equal to" or the symbol ~.

2 isapproximately equal to

3 > 0.6666666667

2

3 = 0.6666666667

Solving an Equation

You can find an exact (symbolic) solution or an approximate (numeric) solution of an equation. For more information
on symbolic and numeric computations, see Symbolic and Numeric Computation (page 80).

To solve an equation:
1. Enter an equation.
2. Display the context menu. See Figure 2.3.

3. From the context menu, select Solve or Numerically Solve in the Solve menu item.
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Copy Special 4
'.-‘xl 5 ] Py 2P
= == Paste Ctrl+V
3 T
v Executable Math Shift+F3

Evaluate and Display Inline  Ctrl+=
Explore

Apply a Command
Approxirmate L4

Assign to a Mame

Combine r
Cross Multiply
Differentiate r

Evaluate at a Point

Integrate L4
Left-hand Side

Manipulate Equation

Map Command Onto

Move to Left

Move to Right

Megate Relation

Plots '
Right-hand Side

Simplify '
Solve '

Isolate Expression for L4
Mumerically Solve

Mumerically Solve (w/complex
Mumerically Solve from point
Obtain Solutions for L4
Solve

Solve (explicit)

Solve (general solution)

Solve for Variable r

Figure 2.3: Finding the Approximate Solution to an Equation

_psove |3 14J112a 41 || 3 -1+ 1120 41

’ 14 T

7><2 X _
3 T 14 T
% X o S 5500603126, 2.337021648
T

For more information on solving equations, including solving inequations, differential equations, and other types of

equations, see Solving Equations (page 86).

Using Units

You can create expressions with units. To specify a unit for an expression, use the Units palettes. The Units (FPS)
palette (Figure 2.4) contains important units from the foot-pound-second (FPS) system of units used in the United
States. The Units (SI) palette (Figure 2.5) contains important units from the international system (SI) of units.
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w Urits (FPS)
[zrit] 2]
[s] [powundal]
[
poundforce
|[ ek’ I
[HP] [[poundal ]
[rad] [sr]1

Figure 2.4: FPS Units Palette

W Units (51}
[zerit] [ ] [s1
[~ [kegl [P=]

I#1 [71 [£]
I71 [A] [¥]
[c1 [« 7]

[#] [rad] [sr]
[moi] [x]  [im]
[s1 [#e] [Ap] |

Figure 2.5: SI Units Palette

To insert an expression with a unit:
1. Enter the expression.

2. In a unit palette, click a unit symbol.
Note: To include a reciprocal unit, divide by the unit.

To evaluate an expression that contains units:
1. Enter the expression using the units palettes to insert units.
2. Right-click (Control-click, for Macintosh) the expression.

3. From the context menu, select Units and then Simplify.

For example, compute the electric current passing through a wire that conducts 590 coulombs in 2.9 seconds.

590C simplify units

203.4482759 A
2.9s

For more information on using units, see Units (page 99).

Assistants and Tutors

Assistants and tutors provide point-and-click interfaces with buttons, text input regions, and sliders. For details on as-
sistants and tutors, see Point-and-Click Interaction (page 26).

Assistants and tutors can be launched from the Tools menu or the context menu for an expression. For example, you
can use the Linear System Solving tutor to solve a linear system, specified by a matrix or a set of equations.
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Example 3 - Using a Context Menu to Open the Linear System Solving Tutor

Use the Linear System Solving tutor to solve the following system of linear equations, written in matrix form:

Action

Result in Document

1. In a new document block, create the matrix or set

. . 1 3 0 -2 -1
of linear equations to be solved.
4 2 -1 5 7
0-3 5 4 -7
1 -1 3 6 5

2. Load the Student[LinearAlgebra] package. From |Loading Student:-LinearAlgebra
the Tools menu, select Load Package — Student
Linear Algebra. This makes the tutors in that
package available. For details, see Package
Commands (page 38).

3. Right-click the matrix and select Student Linear ] L - - 5
Algebra — Tutors — Linear System Solving.... ot iasblnlissilid inaaadicabih .

The Linear System Solving dialog appears, where ||| | - —— ——
you can choose the solving method. Gaussian | Gaussian Elimination | [ Gauss Jordan Elimination ]
Elimination reduces the matrix to row-echelon

form, then performs back-substitution to solve the

system. Gauss Jordan Elimination reduces the

matrix to reduced row-echelon form, where the

equations are already solved. For this example,

choose Gaussian Elimination.

4. The Gaussian Elimination dialog opens. You can || . . . . )
specify the Gaussian elimination step-by-step, or E Lme_ar Algebra - Gaussian Elimination
you can use the Next Step or All Steps buttons to _F'le Edit _Help
have Maple perform the steps for you. 1 -8 67 3|4 - System Solver -

5. Once the matrix is in row-echelon 14 5 -34 10| 2 Cli:k PR any butt:I_" e
(upper-triangular) form, click the Solve System a0 9 230-10 SERSY 8 ROW ORsranion
button to move to the next step. 4 7 17 135 Add multipls

1 v timas
row 1 V add to
row 2 V
Add
Multiphy
2 V times
row 1 v
[ Mulkiphy
Swap
row 1 v with
[ Edit Matrix | [ Solve Syskem ] row 2 e
[ Unida ] [ Mext Step ][ All Steps ] ’ Close ] [ Swap
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Action Result in Document

6. The Solve the system of equations in —— o8
Row-Echelon Form dialog appears. Click the %] Solve the system of equations in Row-Echelon Form .

buttons on the right to calculate the solution: first||| | Linear System of Equations Solve
find the Equations, then solve for each variable. 130 -2]1 ths b
Click the Solution button to display the solution matrix
in the tutor. 4213507 . has =
0D-35 4|7 been
113 6ls reduced
to ramw
13 0o -2 -1 2
N P RS B
10 10 10
145 | 435
"0 53 53
[ Close ] [ Change the matrix ] [ Cancel ]
7. Click the Close button to return the solution to 13 0 -2 -1 4
your document.
4 2 -1 5 7 linear solve tutor 3
0-3 5 4 -7 -2
1-13 6 5 3

For more information on linear systems and matrices, see Linear Algebra (page 119).
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The Worksheet mode of the Standard Worksheet interface is designed for:

* Interactive use through Maple commands, which offers advanced functionality and customized control not available

using context menus or other syntax-free methods

* Programming using the powerful Maple language

Using Worksheet mode, you have access to all of the Maple features described in Chapter 1, and most of those described

in Chapter 2, including:
* Math and Text modes
 Palettes

» Context menus

¢ Assistants and tutors

For information on these features, see Chapter 1, Getting Started (page 1) and Chapter 2, Document Mode (page 49).

Note: Using a document block, you can use all Document mode features in Worksheet mode. For information on

document blocks, see Document Blocks (page 41).

Note: This chapter and the following chapters except Chapter 7 were created using Worksheet mode.

3.1 In This Chapter

Section Topics
Input Prompt (page 62) - Where you enter input * The Input Prompt (>)
* Suppressing Output

2-D and 1-D Math Input

Input Separators

Commands (page 63) - Thousands of routines for performing
computations and other operations

The Maple Library
Top-Level Commands
Package Commands

Lists of Common Commands and Packages

Palettes (page 67) - Items that you can insert by clicking or » Using Palettes
dragging
Context Menus (page 69)- Pop-up menus of common operations|* Using Context Menus

Assistants and Tutors (page 70)- Graphical interfaces with buttons
and sliders

.

Launching Assistants and Tutors

Task Templates (page 71) - Sets of commands with placeholders
that you can insert and use to perform a task

Viewing Task Templates
Inserting a Task Template
Performing the Task

Text Regions (page 72) - Areas in the document in which you
can enter text

Inserting a Text Region

Formatting Text

Names (page 72) - References to the expressions you assign to
them

Assigning to Names
Unassigning Names

Valid Names

61
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Section Topics

Equation Labels (page 74) - Automatically generated labels that
you can use to refer to expressions

Displaying Equation Labels

» Referring to a Previous Result

* Execution Groups with Multiple Outputs
» Label Numbering Schemes

» Features of Equation Labels

3.2 Input Prompt

In Worksheet mode, you enter input at the Maple input prompt ( > ). The default mode for input is Math mode (2-D
Math).

To evaluate input:

¢ Press Enter.

Maple displays the result (output) below the input.

. T .
For example, to find the value of Sln3 [ 3 ] , enter the expression, and then press Enter.

_3(
o)

3 J3 (3.1)
8
For example, compute the sum of two fractions.
2 7
ST
85
— 32
99 (3.2)

Suppressing Output

To suppress the output, enter a colon (:) at the end of the input.

2 7
>9+11.

A set of Maple input and its output are referred to as an execution group.

1-D Math Input

You can also insert input using Text mode (/-D Math). The input is entered as a one-dimensional sequence of characters.
1-D Math input is red.

To enter input using 1-D Math:

At the input prompt, press F5 or click the Text button in the toolbar, Math | to switch from 2-D Math to 1-
D Math.
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> 12372 - 29857/120;

1785623
120

Important: 1-D Math input must end with a semicolon or colon. If you use a semicolon, Maple displays the output;
if you use a colon, Maple suppresses the output.

> 12372 - 29857/120:

To set the default input mode to 1-D Math:

1. From the Tools menu, select Options. The Options dialog is displayed.

2. On the Display tab, in the Input display drop-down list, select Maple Notation.

3. Click Apply to Session (to set for only the current session) or Apply Globally (to set for all Maple sessions).

To convert 2-D Math input to 1-D Math input:
1. Select the 2-D Math input.
2. From the Format menu, select Convert To, and then 1-D Math Input.

Important: In Document mode, you can execute a statement only if you enter it in Math mode.

Input Separators

In 1-D and 2-D Math input, you can use a semicolon or colon to separate multiple inputs in the same input line.

>, 4.4 ;tan(3.2)
2.097617696
0.05847385446

If you do not specify a semicolon or colon, Maple interprets it as a single input. This can either give unexpected results,
as below, or an error.

>,/ 4.4 tan(3.2)
0.1226557919

3.3 Commands

Maple contains a large set of commands and a powerful programming language. Most Maple commands are written
using the Maple programming language.

You can enter commands using 1-D or 2-D Math. You must use 1-D Math input when programming in Maple. Basic
Programming (page 287) provides an introduction to Maple programming.

To learn how to use Maple commands, see the appropriate help page, or use task templates. For more information, see
The Maple Help System (page 43) and Task Templates (page 71).

The Maple Library

Maple's commands are contained in the Maple library. There are two types of commands: fop-level commands and
package commands.

* The top-level commands are the most frequently used Maple commands.
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» Packages contain related specialized commands in areas such as calculus, linear algebra, vector calculus, and code
generation.

For a complete list of packages and commands, refer to the index help pages. To access the index overview help page,
enter ?index, and then press Enter. For information on the Maple Help System, see The Maple Help System (page 43).

Top-Level Commands

To use a top-level command, enter its name followed by parentheses (( )) containing any parameters. This is referred
to as a calling sequence for the command.

| command (arguments)

Note: In 1-D Math input, include a semicolon or colon at the end of the calling sequence.

For example, to differentiate an expression, use the diff command. The required parameters are the expression to dif-
ferentiate, which must be specified first, and the independent variable.

> diff(tan(x) sin(x), x)
(1 + tan(x)2> sin(x) + tan(x) cos(x)

For a complete list of functions (commands that implement mathematical functions), such as Bessell and AiryAli,
available in the library, refer to the initialfunctions help page.

- Bessell(0.1, 1)
AiryAi(2.2)

47.53037086

For detailed information on the properties of a function, use the FunctionAdvisor command.

> FunctionAdvisor( 'definition', Bessell)

z* hypergeom[[ 1,[1+ al, 1 22]

Bessell(a, z) = , With no restrictions on (a, z)

(1 +a)?2“
For detailed information on how to use a function in Maple, refer to its help page.
For example:
> 7 Bessel

Note: In 1-D and 2-D Math input, when accessing a help page using ?, you do not need to include a trailing semicolon
or colon.

Top Commands

Here are a few of the most frequently used Maple commands. A complete list of top-level commands is available at
Help — Manuals, Resources, and more — List of Commands.

Table 3.1: Top Commands

Command Name Description

plot and plot3d Create a two-dimensional and three-dimensional plot of functions.

solve Solve one or more equations or inequalities for their unknowns.
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Command Name Description

fsolve Solve one or more equations using floating-point arithmetic.

eval Evaluate an expression at a given point.

evalf Numerically evaluate expressions.

dsolve Solve ordinary differential equations (ODEs).

int Compute an indefinite or definite integral.

diff Compute an ordinary or partial derivative, as the context dictates.

limit Calculate the limiting value of a function.

sum For symbolic summation. It is used to compute a closed form for an indefinite or definite sum.

assume/is Set variable properties and relationships between variables. Similar functionality is provided by the
assuming command.

assuming Compute the value of an expression under assumptions.

simplify Apply simplification rules to an expression.

factor Factor a polynomial.

expand Distribute products over sums.

normal Normalize a rational expression.

convert Convert an expression to a different type or form.

type Type-checking command. In many contexts, it is not necessary to know the exact value of an
expression; it suffices to know that an expression belongs to a broad class, or group, of expressions
that share some common properties. These classes or groups are known as fypes.

series Generalized series expansion.

map Apply a procedure to each operand of an expression.

Package Commands

To use a package command, the calling sequence must include the package name, and the command name enclosed
in square brackets ([ ]).

|pa ckage[command] (arguments)

If you are frequently using the commands in a package, load the package.

To load a package:

» Use the with command, specifying the package as an argument.

The with command displays a list of the package commands loaded (unless you suppress the output by entering a colon
at the end of the calling sequence).

After loading a package, you can use the short form names of its commands. That is, you can enter the commands
without specifying the package name.
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For example, use the NLPSolve command from the Optimization package to find a local minimum of an expression
and the value of the independent variable at which the minimum occurs.

> Optimization| NLPSolve] ( &X(x) x=1 ..15)

[-0.0913252028230576718, [x=10.9041216700744900] ]

> with(Optimization);

[ ImportMPS, Interactive, LPSolve, LSSolve, Maximize, Minimize, NLPSolve, QPSolve]
> NLPSolve[ &X(X) x=1 ..15]

[-0.0913252028230576718, [x=10.9041216700744900] |
For more information on optimization, see Optimization (page 142).
To unload a package:
» Use the unwith command, specifying the package as an argument.
> unwith(Optimization)

Alternatively, use the restart command. The restart command clears Maple's internal memory. The effects include
unassigning all names and unloading all packages. For more information, refer to the restart help page.

Note: To execute the examples in this manual, you may be required to use the unassign or restart command between
examples.

Some packages contain commands that have the same name as a top-level command. For example, the plots package
contains a changecoords command. Maple also contains a top-level changecoords command.

> with(plots) :

After the plots package is loaded, the name changecoords refers to the plots[changecoords] command. To use the
top-level changecoords command, unload the package or use the restart command. (For alternative methods of accessing
the top-level command, see the rebound help page.)

Top Packages

Here are a few of the most frequently used Maple packages. A complete list of packages is available in the Maple help
system at Help — Manuals, Resources, and more — List of Packages.

Table 3.2: Top Packages

Package Name Description

CodeGeneration The Code Generation package is a collection of commands and subpackages that enable the
translation of Maple code to other programming languages, such as C, C#, Fortran, MATLAB®,
Visual Basic®, JavaTM, Julia, Perl, and Pyth0n®.

LinearAlgebra The Linear Algebra package contains commands to construct and manipulate Matrices and
Vectors, and solve linear algebra problems. LinearAlgebra routines operate on three principal
data structures: Matrices, Vectors, and scalars.

Optimization The Optimization package is a collection of commands for numerically solving optimization
problems, which involve finding the minimum or maximum of an objective function possibly
subject to constraints.
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Package Name Description

Physics The Physics package implements computational representations and related operations for most
of the objects used in mathematical physics computations.

RealDomain The Real Domain package provides an environment in which Maple assumes that the basic
underlying number system is the field of real numbers instead of the complex number field.

ScientificConstants The Scientific Constants package provides access to the values of various physical constants,

for example, the velocity of light and the atomic weight of sodium. This package provides the
units for each of the constant values, allowing for greater understanding of an equation. The
package also provides units-matching for error checking of the solution.

ScientificErrorAnalysis

The Scientific Error Analysis package provides representation and construction of numerical
quantities that have a central value and an associated uncertainty (or error), which is a measure
of the degree of precision to which the quantity's value is known. Various first-order calculations
of error analysis can be performed with these quantities.

Statistics

The Statistics package is a collection of tools for mathematical statistics and data analysis. The
package supports a wide range of common statistical tasks such as quantitative and graphical
data analysis, simulation, and curve fitting.

Student

The Student package is a collection of subpackages designed to assist with teaching and learning
standard undergraduate mathematics. The many commands display functions, computations, and
theorems in various ways, including stepping through important computations.

The Student package contains the following subpackages:
* Basics - fundamental math concepts

» Calculusl - single-variable calculus

* LinearAlgebra - linear algebra

* MultivariateCalculus - multivariate calculus

* NumericalAnalysis - numerical analysis

* Precalculus - precalculus

¢ VectorCalculus - multivariate vector calculus

Units

The Units package contains commands for unit conversion and provides environments for
performing calculations with units. It accepts approximately 300 distinct unit names (for example,
meters and grams) and over 550 units with various contexts (for example, standard miles and
U.S. survey miles). Maple also contains two Units palettes that allow you to enter the unit for
an expression quickly.

VectorCalculus

The Vector Calculus package is a collection of commands that perform multivariate and vector
calculus operations. A large set of predefined orthogonal coordinate systems is available. All
computations in the package can be performed in any of these coordinate systems. It contains a
facility for adding a custom but orthogonal coordinate system and using that new coordinate
system for your computations.

3.4 Palettes

Palettes are collections of related items that you can insert by clicking or dragging. For example, see Figure 3.1.
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W Calculus
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Figure 3.1: Calculus Palette
You can use palettes to enter input.
[ dx
For example, evaluate a definite integral using the definite integration item *, in the Calculus palette.

In 2-D Math, clicking the definite integration item inserts:

X
2

>J £ dx
X

1. Enter values in the placeholders. To move to the next placeholder, press Tab.

2. To evaluate the integral, press Enter.

1
>J tanh(x) dx
0

-In(2) —Hn(e'1 +e)
In 1-D Math, clicking the definite integration item inserts the corresponding command calling sequence.
> int(int(f,x=a..b);,x=x[1]..x[2]);

Specify the problem values (using the Tab to move to the next placeholder), and then press Enter. Note: If pressing

=]
rg

g

the Tab key inserts a tab, click the Tab icon || in the toolbar.

> int(tanh(x), x = 0..1);
-In(2) +ln(e_1 +e)

Note: Some palette items cannot be inserted into 1-D Math because they are not defined in the Maple language. When
the cursor is in 1-D Math input, unavailable palette items are dimmed.

For more information on viewing and using palettes, see Palettes (page 18) in Chapter 1.
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3.5 Context Menus

A context menu is a popup menu that lists the operations and actions you can perform on a particular expression. See
Figure 3.2.

> 946929
946929

Copy Special ]
Mumeric Farmatting...
Explore

Apply a Command

Assign ko a Name

Integer Fackars

Mexk Prime

Test Primality

Mare... ]

Mumber Theory Functions b Divisors
Murnber of Positive Divisors

Mumber of Primes
Surn of Divisors

Totient Function
Figure 3.2: Integer Context Menu

In Worksheet mode, you can use context menus to perform operations on 2-D Math and output.

To use a context menu:
1. Right-click (Control-click, for Macintosh) the expression. The context menu is displayed.

2. From the context menu, select an operation.

Maple inserts a new execution group containing:
 The calling sequence that performs the operation

* The result of the operation
Example - Using Context Menus

Determine the rational expression (fraction) that approximates the floating-point number 0.3463678 + 1.7643.

Action Result in Document
1. Enter and execute the expression. > 0.3463678 + 1.7643

2.1106678 (33)
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Action

Result in Document

2. Right-click (Control-click, for Macintosh) the output
floating-point number.

2.1106678

Copy Special

Murneric Farmatking. ..

Explore

Apply a Command
Assign bo a Marme
Mextk Float
Prewious Float

Conversions
Integer Functions
Urits

]
4
¥

Zonkinued Fraction

Exact Rational

R.akional %

3. From the context menu, select Conversions — Rational. The
inserted calling sequence includes an equation label reference
to the number you are converting.

> convert( (3.3), 'rational )

32270
15289

Notice that an equation label reference has been used. For information on equation labels and equation label references,

see Equation Labels (page 74).

For more information on context menus, see Context Menus (page 54) in Chapter 2.

3.6 Assistants and Tutors

Assistants and tutors provide point-and-click interfaces with buttons, text input regions, and sliders. See Figure 3.3.

(%] oDE Analyzer Assistant
Differential Equations Conditions
- ¢ () =1

FY =)

I Solve Numerically l[ Solve Symbalically ][ Classify ]

Paramekers

Figure 3.3: ODE Analyzer Assistant

Launching an Assistant or Tutor

To launch an assistant or tutor:
1. Open the Tools menu.
2. Select Assistants or Tutors.

3. Navigate to and select one of the assistants or tutors.

For more information on assistants and tutors, see Assistants (page 26) in Chapter 1.
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3.7 Task Templates

Maple can solve a diverse set of problems. The task template facility helps you quickly find and use the commands
required to perform common tasks.

After inserting a task template, specify the parameters of your problem in the placeholders, and then execute the com-
mands, or click a button.

The Task Browser (Figure 3.4) organizes task templates by subject.

To launch the Task Browser:

* From the Tools menu, select Tasks, and then Browse.

You can also browse the task templates in the Table of Contents of the Maple Help System.

r@ Browse Tasks | = | =] 2 .|1

File WView
----- Owerview 4 - —
N l Copy Task to Clipboard l l Insert Default Content l l Insert Minimal Content l
[ | Algebra
B [ Caleulus - Differential [ Insert into Mew Worksheet [ Display task markers
= |y Caleulus - Integral
[#- | Integration -
e Approximats Integraton ¥ Volume of Revolution
[#- |, Methods of Integration
=+ 1. Applications

: Arc Length of a Univariate Function Description

. Solids of Revalution
- [1] surface Area

m

Calculate the volume of revolution for a selid of revolution when
[#- || Series a function is rotated about the horizontal or vertical axis.
[ | Calculus - Multivariate . . .
[ | Caloulus - Vector Enter the function as an expression and specify the range:
----- Convert Expression to Function b
[~ |, Curve Fitting ) -
[#- | Differential Equations > sin(x) cos(x) + l,ﬂ__T
[ || Document Templates - 1
(- |, eBook Metadata sin(_'c) COSI:_'C) + 1.0 oy T (1)
[ | Evaluating 2
[ ) Geometry
(- [ Integers Calculate the volume of revolution:
[ | Linear Algebra
g: - :itsle a > Student| Calculus 1] VolumeOfRevolution]( (1))
B~ Jy Plots T+ i ].tl 2
- |, Polynomials 16
[#- |, Stafistics
- |y Transformations Display the floating-point value using the evalf command:
[ | Units, Constants, and Errors
[}y User Tasks

> evalf((2))
8693245131 3)

Display a plot using the owput=plor option:

> Student| Calculus I'[ VolumeOfRevolution]( (1), output = plot,
scaling = constrained caption="")

4 [T | 3

Task VolumeOfRevUnivariateFcn

Figure 3.4: Task Browser
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For details on inserting and using task templates, see Tusk Templates (page 33). You can also create your own task
templates for performing common tasks. For details, refer to the creatingtasks help page.

3.8 Text Regions
To add descriptive text in Worksheet mode, use a text region.

To insert a text region:

* In the toolbar, click the Text region icon I .
The default mode in a text region is Text mode.

In a text region, you can:

* Enter text with inline mathematical content by switching between Text and Math modes. To toggle between Text

mode and Math mode, press F5 or click the Math and Text toolbar icons, Math
Note: The mathematical content in a text region is not evaluated. To enter mathematical content that is evaluated,
enter it at an Input Prompt (page 62).

* Insert any palette item. Palette items are inserted in Math mode (2-D Math). Note: After you insert a palette item,
you must press F5 or click the toolbar icon to return to Text mode.

You can format text in a text region. Features include:
* Character styles

 Paragraph styles

+ Sections and subsections

e Tables

For more information on formatting documents, see Creating Mathematical Documents (page 221).

3.9 Names

Instead of re-entering an expression every time you need it, you can assign it to a name or add an equation label to it.
Then you can quickly refer to the expression using the name or an equation label reference. For information on labels,
see the following section, Equation Labels (page 74).

Note: Through the Variable Manager you can manage the top-level assigned variables currently active in your Maple
Session. For more information about the Variable Manager, see the Variable Manager help page. For Maple workbooks,
you can use the Variable Manager palette to return to the saved state of your variables.

Assigning to Names

You can assign any Maple expression to a name: numeric values, data structures, procedures (a type of Maple program),
and other Maple objects.

Initially, the value of a name is itself.
>da
a

The assignment operator (:=) associates an expression with a name.
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a.=m

Recall that you can enter 7 using the following two methods.
* Use the Common Symbols palette.

* In 2-D Math enter pi, and then press the symbol completion shortcut key. See Shortcuts for Entering Mathematical
Expressions (page 5).

When Maple evaluates an expression that contains a name, it replaces the name with its value. For example:
> cos(a)
-1
For information on Maple evaluation rules, see Evaluating Expressions (page 279).
Mathematical Functions
To define a function, assign it to a name.

For example, define a function that computes the cube of its argument.

> cube = x X

For information on creating functions, see Example 2 - Define a Mathematical Function (page 51).

> cube(3); cube(1.666)
27
4.624076296

Note: To insert the right arrow, enter the characters ->. In 2-D Math, Maple replaces -> with the right arrow symbol —.
In 1-D Math, the characters are not replaced.

For example, define a function that squares its argument.
> square := x -> x"2:

> square (32) ;
1024
For more information on functions, see Functional Operators (page 268).
Protected Names
Protected names are valid names that are predefined or reserved.
If you attempt to assign to a protected name, Maple returns an error.
>sin:=2
Error, attempting to assign to 'sin’ which is protected

For more information, refer to the type/protected and protect help pages.



74 + 3 Worksheet Mode

Unassigning Names
The unassign command resets the value of a name to itself. Note: You must enclose the name in right single quotes
(V V).

> unassign('a')

>da
a

Right single quotes (unevaluation quotes) prevent Maple from evaluating the name. For more information on unevaluation
quotes, see Delaying Evaluation (page 285) or refer to the uneval help page.

See also Unassigning a Name Using Unevaluation Quotes (page 286).
Unassigning all names:

The restart command clears Maple's internal memory. The effects include unassigning all names. For more information,
refer to the restart help page.

Note: To execute the examples in this manual, you may be required to use the unassign or restart command between
examples.

Valid Names

A Maple name must be one of the following.
» A sequence of alphanumeric and underscore (_) characters that begins with an alphabetical character.

» A sequence of characters enclosed in left single quotes (" °).

Important: Do not begin a name with an underscore character. Maple reserves names that begin with an underscore
for use by the Maple library.

Examples of valid names:

*a

» al

* polynomial

* polynomiall_divided_by_polynomial2
o 2a

oy
3.10 Equation Labels

Maple marks the output of each execution group with a unique equation label.

Note: The equation label is displayed to the right of the output.
> Jsin(x) dx

-cos(x) (3.4)

Using equation labels, you can refer to the result in other computations.
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> J(3 .4) dx
-sin(x) (3.5)

Displaying Equation Labels

Important: By default, equation labels are displayed. If equation label display is turned off, complete both of the
following operations.

* From the Format menu, select Equation Labels, and then ensure that Worksheet is selected.

* In the Options dialog (Tools—Options), on the Display tab, ensure that Show equation labels is selected.

Referring to a Previous Result

Instead of re-entering previous results in computations, you can use equation label references. Each time you need to
refer to a previous result, insert an equation label reference.

To insert an equation label reference:
1. From the Insert menu, select Label. (Alternatively, press Ctrl+L; Command+L, Macintosh.)

2. In the Insert Label dialog (see Figure 3.5), enter the label value, and then click OK.

Insert Label
Tvpe: Equation v
Identifier:

I QK l l Cancel

Figure 3.5: Insert Label Dialog
Maple inserts the reference.
For example:

To integrate the product of (3.4) and (3.5):

Action Result in Document
1. In the Expression palette, click the indefinite integration item r
B > | fdx
J Sy . .. . . -
. The item is inserted and the integrand placeholder is
highlighted.
2. Press Ctrl+L (Command+L, for Macintosh). - [ - de
3. In the Insert Label dialog, enter 3.4. Click OK. Insert Label
Tvpe: Equation V
Tdentifier: | 3.4|
[ oK ] [ Cancel
4. Press *. r
> [(3.4)(3.5)dx
5. Press Ctrl+L (Command+L, for Macintosh). -
6. In the Insert Label dialog, enter 3.5. Click OK.
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Action

Result in Document

7. To move to the variable of integration placeholder, press Tab.

>J(3.4)-(3.5) dx

8. Enter x.
9. To evaluate the integral, press Enter. 1 cos( X)Z (3.6)
> .
Execution Groups with Multiple Outputs
An equation label is associated with the last output within an execution group.
(55 o)
3.5)° 6
0.3265306122
% J3 (3.7)

> (3.7)°

3

— 3.8

4 (3.8

Label Numbering Schemes

You can number equation labels in two ways:

* Flat - Each label is a single number, for example, 1, 2, or 3.

* Sections - Each label is numbered according to the section in which it occurs. For example, 2.1 is the first equation

in the second section, and 1.3.2 is the second equation in the third subsection of the first section.

To change the equation label numbering scheme:

* From the Format menu, select Equation Labels — Label Display. In the Format Labels dialog (Figure 3.6), select
one of the formats.

* Optionally, enter a prefix.

[) ".sm(x) dx

|:> [f( Questionl) dx

—cos(x) (Cuestion1)

Format Labels

Label Mumbering Prefix | Guestion

Label Mumbering Scheme | Flak Murneric

I oK l l Cancel

Figure 3.6: Format Labels Dialog: Adding a Prefix
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Features of Equation Labels

Although equation labels are not descriptive names, labels offer other important features.
» Each label is unique, whereas a name may be inadvertently assigned more than once for different purposes.

* Maple labels the output values sequentially. If you remove or insert an output, Maple automatically re-numbers all
equation labels and updates the label references.

» Ifyou change the equation label format (see Label Numbering Schemes (page 76)), Maple automatically updates
all equation labels and label references.

For information on assigning to, using, and unassigning names, see Names (page 72).
For more information on equation labels, refer to the equationlabel help page.

The following chapters describe how to use Maple to perform tasks such as solving equations, producing plots and
animations, and creating mathematical documents. The chapters were created using Worksheet mode. Except where
noted, all features are available in both Worksheet mode and Document mode.
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4 Basic Computations

This chapter discusses key concepts related to performing basic computations with Maple. It discusses important features
that are relevant to all Maple users. After learning about these concepts, you will learn how to use Maple to solve

problems in specific mathematical disciplines in the following chapter.

4.1 In This Chapter

Section

Topics

Symbolic and Numeric Computation (page 80)- An overview of
exact and floating-point computation

* Exact Computations
* Floating-Point Computations
» Converting Exact Quantities to Floating-Point Values

* Sources of Error

Integer Operations (page 82) - How to perform integer
computations

* Important Integer Commands
* Non-Base 10 Numbers
* Finite Rings and Fields

* Gaussian Integers

Solving Equations (page 86) - How to solve standard
mathematical equations

» Equations and Inequations

* Ordinary Differential Equations

* Partial Differential Equations

* Integer Equations

 Integer Equations in a Finite Field
* Linear Systems

¢ Recurrence Relations

Units, Scientific Constants, and Uncertainty (page 99) - How to
construct and compute with expressions that have units, scientific
constants, or uncertainty

Units

» Conversions

* Applying Units to an Expression

* Performing Computations with Units
* Changing the Current System of Units
 Extensibility

Scientific Constants

* Scientific Constants

» Element and Isotope Properties
¢ Value, Units, and Uncertainty

* Performing Computations

* Modification and Extensibility

Uncertainty Propagation

* Quantities with Uncertainty

» Performing Computations with Quantities with Uncertainty

79
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Section Topics

Restricting the Domain (page 109) - How to restrict the domain |« Real Number Domain
for computations

* Assumptions on Variables

4.2 Symbolic and Numeric Computation

Symbolic computation is the mathematical manipulation of expressions involving symbolic or abstract quantities, such

as variables, functions, and operators; and exact numbers, such as integers, rationals, 7, and ez. The goal of such ma-
nipulations may be to transform an expression to a simpler form or to relate the expression to other, better understood
formulas.

Numeric computation is the manipulation of expressions in the context of finite-precision arithmetic. Expressions in-

volving exact numbers, for example, / 2 , are replaced by close approximations using floating-point numbers, for
example 1.41421. These computations generally involve some error. Understanding and controlling this error is often
of as much importance as the computed result.

In Maple, numeric computation is normally performed if you use floating-point numbers (numbers containing a
decimal point) or the evalf command. The plot command (see Plots and Animations (page 187)) uses numeric compu-
tation, while commands such as int, limit, and ged (see Integer Operations (page 82) and Mathematical Problem
Solving (page 113)) generally use only symbolic computation to achieve their results.

Exact Computations

In Maple, integers, rational numbers, mathematical constants such as 7 and o, and mathematical structures such as
matrices with these as entries are treated as exact quantities. Names, such as X, y, my_variable, and mathematical

functions, such as sin(x) and LambertW(k, z), are symbolic objects. Names can be assigned exact quantities as
their values, and functions can be evaluated at symbolic or exact arguments.

3
5> 2

1
—1
2+3’ *

Ea
2

11 1
6,1+2n

Important: Unless requested to do otherwise (see the following section), Maple evaluates expressions containing exact
quantities to exact results, as you would do if you were performing the calculation by hand, and not to numeric approx-
imations, as you normally obtain from a standard hand-held calculator.
> sin(1), sin( ), sin(x)

sin(1), 0, sin(x)

> J tan(t) dt

-In(cos(t))

> /32
42
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Floating-Point Computations

In some situations, a numeric approximation of an exact quantity is required. For example, the plot command requires
the expression it is plotting to evaluate to numeric values that can be rendered on the screen: m cannot be so rendered,

but 3.14159 can be. Maple distinguishes approximate from exact quantities by the presence or absence of a decimal

point: 1.9 is approximate, while 19 is exact.

10

Note: An alternative representation of floating-point numbers, called e-notation, may not include an explicit decimal
point: 7e5 = 100000., 3e-2 =.03.

In the presence of a floating-point (approximate) quantity in an expression, Maple generally computes using numeric
approximations. Arithmetic involving mixed exact and floating-point quantities results in a floating-point result.

2
1.5+ -
> + 3

2.166666667

If a mathematical function is passed a floating-point argument, it normally attempts to produce a floating-point approx-
imation of the result.

1.0
> sin(l.S),J e dx
0.0

0.9974949866, 1.718281828

Converting Exact Quantities to Floating-Point Values

To convert an exact quantity to a numeric approximation of that quantity, use the evalf command or the Approximate
context menu operation (see Approximating the Value of an Expression (page 55)).

> evalf(r), evalf(sin(3)), evalf(;Jr;J

3.141592654, 0.1411200081, 1.833333333

By default, Maple computes such approximations using 10 digit arithmetic. You can modify this in one of two ways:

* Locally, you can pass the precision as an index to the evalf call.

> evalf[20](exp(2)), evalf( r(%))

7.3890560989306502272, 1.354117939

* Globally, you can set the value of the Digits environment variable.

> Digits := 25 :
> evalf(tan[ % ] ]

For more information, see the evalf and Digits help pages.

1.732050807568877293527446
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Note: When appropriate, Maple performs floating-point computations directly using your computer's underlying
hardware.

Sources of Error

By its nature, floating-point computation normally involves some error. Controlling the effect of this error is the subject
of active research in Numerical Analysis. Some sources of error are:

. . . 1
* An exact quantity may not be exactly representable in decimal form: 3 and 7 are examples.

* Small errors can accumulate after many arithmetic operations.

» Subtraction of nearly equal quantities can result in essentially no useful information. For example, consider the
computation X — sin(x) for x = 0.

> (x—sin(x))
x=.00001

0.

No correct digits remain. If, however, you use Maple to analyze this expression, and replace this form with a represent-

ation that is more accurate for small values of X, a fully accurate 10-digit result can be obtained.
> t:= taylor(x—sin(x), x)

t:= 1 X 1 X +O(x6)

>

x=0.00001

1.666666667 107 1°

For information on evaluating an expression at a point, see Substituting a Value for a Subexpression (page 279). For
information on creating a series approximation, see Series (page 137). For more information on floating-point numbers,
refer to the float and type/float help pages.

4.3 Integer Operations

In addition to the basic arithmetic operators, Maple has many specialized commands for performing more complicated
integer computations, such as factoring an integer, testing whether an integer is a prime number, and determining the
greatest common divisor (GCD) of a pair of integers.

Note: Many integer operations are available as task templates (Tools— Tasks— Browse, under Integers).

You can quickly perform many integer operations using context menus. Selecting an integer, and then right-clicking
(for Macintosh, Control-clicking) displays a context menu with integer commands. For example, the context menu
item Integer Factors applies the ifactor command to compute the prime factorization of the given integer. See
Figure 4.1.
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9469629
9469629

Figure 4.1: Context Menu for an Integer

Copy Special

Murneric Farmatking. ..

Explore

Apply a Command
Assign bo a Marme
Integer Factars
Mexk Prime

Plots

Test Primality

Integer Functions
Lnits

tumber Theory Functions

The result of applying Integer Factors is shown:

> 9469629

> ifactor((4.1))

9469629

(3)* (13) (17) (23)°

@.1)

4.2)

Maple inserts the command ifactor, using an equation label reference to the integer 946929. For more information on
equation labels, see Equation Labels (page 74).

For more information on using context menus in Worksheet mode, see Context Menus (page 69). For information on
using context menus in Document mode, see Context Menus (page 54).

Maple has many other integer commands, including those listed in Table 4.1.

Table 4.1: Select Integer Commands

Command Description

abs absolute value (displays in 2-D math as |al)
factorial factorial (displays in 2-D math as a!)
ifactor prime factorization

iged greatest common divisor

iquo quotient of integer division

irem remainder of integer division

iroot integer approximation of nth root

isprime test primality

isqrt integer approximation of square root

max, min maximum and minimum of a set

mod modular arithmetic (See Finite Rings and Fields (page 84).)
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Command Description

numtheory[divisors| set of positive divisors

> iquo(209,17)

12
> irem(209,17)

5
> iged(2024, 4862)

22
> iroot(982523, 4)

31

For information on finding integer solutions to equations, see Integer Equations (page 97).

Non-Base 10 Numbers and Other Number Systems

Maple supports:
* Non-base 10 numbers
* Finite ring and field arithmetic

* Gaussian integers
Non-Base 10 Numbers
To represent an expression in another base, use the convert command.
> convert(6000, 'binary’)
1011101110000

> convert(34271, 'heX)
85DF

For information on enclosing keywords in right single quotes ('), see Delaying Evaluation (page 285).
You can also use the convert/base command.
> convert(34271, 'base', 16)

[15,13,5, 8]
Note: The convert/base command returns a list of digit values in order of increasing significance.
Finite Rings and Fields

Maple supports computations over the integers modulo m.

The mod operator evaluates an expression over the integers modulo m.
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> 27 mod 4
3

By default, the mod operator uses positive representation (modp command). Symmetric representation is available
using the mods command.

> modp(27, 4)

> mods(27, 4)

-1
For information on setting symmetric representation as the default, refer to the mod help page.
The modular arithmetic operators are listed in Table 4.2.

Table 4.2: Modular Arithmetic Operators

Operation Operator |Example
Addition + >7 +6mod5
3
Subtraction - > mods(3 — 16, 11)
-2
Multiplication (displays in 2-D Math as - ) * >13-5mod 3
2
TSR : X ~
ls\:llgletrlz)cllfggve inverse (displays in 2-D Math as a (-1) S 3(_1 )mod 5
2
Division (displays in 2-D Math as % ) / > % mod 5
4
Exponentiation' &* > (100&*100)mod 7
2
'To enter a caret (") in 2-D Math, enter a backslash character followed by a caret, that is, \".

For information on solving an equation modulo an integer, see Integer Equations in a Finite Field (page 98).

The mod operator also supports polynomial and matrix arithmetic over finite rings and fields. For more information,
refer to the mod help page.

Gaussian Integers
Gaussian integers are complex numbers in which the real and imaginary parts are integers.
The GaussInt package contains commands that perform Gaussian integer operations.

The GIfactor command returns the Gaussian integer factorization.
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> GaussInt| GIfactor] (173 + 16 I)
(1+21) (41 —661)

In Maple, complex numbers are represented as a+b*I, where the uppercase I represents the imaginary unit / -1 .
You can also enter the imaginary unit using the following two methods.

+ In the Common Symbols palette, click the I, 1 or j item. See Palettes (page 18).
» Enter i or j, and then press the symbol completion key. See Symbol Names (page 23).

Note that the output will still be displayed with I, no matter what symbol was used for input. You can customize Maple's

settings to use a different symbol for y/ -1 . For more information on entering complex numbers, including how to
customize this setting, refer to the HowDol/Enter AComplexNumber help page.

The GIsqrt command approximates the square root in the Gaussian integers.
> GaussInt[ GIsqrt] (9 — 5 j)
3—1

For more information on Gaussian integers including a list of GaussInt package commands, refer to the GaussInt
help page.

4.4 Solving Equations
You can solve a variety of equation types, including those described in Table 4.3.

Table 4.3: Overview of Solution Methods for Important Equation Types

Equation Type Solution Method

Equations and inequations solve and fsolve commands

Ordinary differential equations ODE Analyzer Assistant (and dsolve command)
Partial differential equations pdsolve command

Integer equations isolve command

Integer equations in a finite field msolve command

Linear integral equations intsolve command

Linear systems LinearAlgebra|LinearSolve] command
Recurrence relations rsolve command

Note: Many solve operations are available in context menus and as task templates (Tools—Tasks—Browse). Most
of this section focuses on other methods.

Solving Equations and Inequations

Using Maple, you can symbolically solve equations and inequations. You can also solve equations numerically.

To solve an equation or set of equations using context menus:
1. Right-click (for Macintosh, Control-click) the equations.

2. From the context menu, select Solve (or Solve Numerically). See Figure 4.2.
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Figure 4.2: Context Menu for an Equation

In Worksheet mode, Maple inserts a calling sequence that solves the equation followed by the solutions.

If you select Solve, Maple computes exact solutions.

L 7X

=12
3 X

LR
L —x=12
3 X

> solve( {(4.3)})

R L]

T 14 14 T 141

If you select Solve Numerically, Maple computes floating-point solutions.

L 7X

=12
3 X

AP
L —x=12
3 X

> fsolve( {(4.5)})
{x=-2.063602674}, {x = 2.492174103}

4.3)

“44

(4.5)

(4.6)
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For information on solving equations and inequations symbolically using the solve command, see the following section.
For information on solving equations numerically using the fsolve command, see Numerically Solving
Equations (page 90).

Symbolically Solving Equations and Inequations

The solve command is a general solver that determines exact symbolic solutions to equations or inequations. The
solutions to a single equation or inequation are returned as an expression sequence. For details, see Creating and Using
Data Structures (page 263). If Maple does not find any solutions, the solve command returns the empty expression se-
quence.

>solve(x2+3x+14=0)

+

N | wo

Iv47, —% —%I\/47

N | =

In general, solve computes solutions in the field of complex numbers. To restrict the problem to only real solutions,
see Restricting the Domain (page 109).

It is recommended that you verify the solutions returned by the solve command. For details, see Working with
Solutions (page 91).

To return the solutions as a list, enclose the calling sequence in brackets (] |).
> [SOIve(x2 + x=256Y, x)]

1.1 11
[2+2\/1+1024y, 55

J1+1024y

Expressions: You can specify expressions instead of equations. The solve command automatically equates them to
ZETo0.

> solve(e? + z)
-LambertW(1)

Multiple Equations: To solve multiple equations or inequations, specify them as a Creating and Using Data
Structures (page 263).

> solve([xy2 —y=5x> O])
S
> solve({xy2 —y=5x< 0})
{x: y+5 y+5 _y+5
Solving for Specific Unknowns: By default, the solve command returns solutions for all unknowns. You can specify
the unknowns for which to solve.

, -5 <y,y<0

, ¥ <-5
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> Solve[q2 —rs+ % =5, 6]]

1 -1+J1+44s+20° 1 1+J1+4P°s+207°
2 r 2 r

To solve for multiple unknowns, specify them as a list.

we[[d_ T 4 4a_5 =1]” )
>S0V€[{S s+1+r rs [qr]
_ 58 +1+5s _ 1
S+1+5 +¢ S

Transcendental Equations: In general, the solve command returns one solution to transcendental equations.
> equationl = sin(x) = cos(X) :
> solve(equationl)
S T
4
To produce all solutions, use the allsolutions option.

> solve(equationl, allsolutions = true)

1
—n+mn_Zl~
4 T+w

Maple uses variables of the form _ZN~, where N is a positive integer, to represent arbitrary integers. The tilde (~) in-
dicates that it is a quantity with an assumption. For information about names with assumptions, see Assumptions on
Variables (page 110).

RootOf Structure: The solve command may return solutions, for example, to higher order polynomial equations, in
an implicit form using RootOf structures.

> [Solve(x5 —2xt 43X - 2)]

[1, RootOf(_Z — _Z2 +2 72 +2 _Z+2,index=1), RootOf(_Z* — _7Z° +2 _7> + 2 _Z+ 2, index
=2), RootOf(_Z* — _Z° +2 _Z* +2 _Z+2, index=3), RootOf(_Z* — 2 +2 _Z* +2 _Z+?2,
index = 4) ]

These RootOf structures are placeholders for the roots of the equation #A-7 +2 7 + 2 z + 2. The index para-
meter numbers and orders the four solutions.

Like any symbolic expression, you can convert RootOf structures to a floating-point value using the evalf command.

> evalf((4.7))

[1.,0.984001051867989 + 1.52659083388421 [, -0.484001051867989 + 0.6099471404862311,
-0.484001051867989 — 0.6099471404862311, 0.984001051867989 — 1.52659083388421 1]
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Some equations are difficult to solve symbolically. For example, polynomial equations of order five and greater do
not in general have a solution in terms of radicals. If the solve command does not find any solutions, it is recommended
that you use the Maple numerical solver, fsolve. For information, see the following section, Numerically Solving
Equations.

For more information on the solve command, including how to solve equations defined as procedures and how to find
parametric solutions, refer to the solve/details help page.

For information on verifying and using solutions returned by the solve command, see Working with Solutions (page 91).

Numerically Solving Equations

The fsolve command solves equations numerically. The behavior of the fsolve command is similar to that of the solve
command.

> equation2:= z cos(z) = 2:
> fsolve(equation2, z)
23.64662473 (4.8)

Note: You can also numerically solve equations using the context menus. See Solving Equations and
Inequations (page 86).

It is recommended that you verify the solutions returned by the fsolve command. For details, see Working with
Solutions (page 91).

Multiple Equations: To solve multiple equations, specify them as a set. For more information, see Creating and Using
Data Structures (page 263). The fsolve command solves for all unknowns.

> fsolve({In(x) =y* + 1,xy =¢"})
{x=3.396618823, y=10.4719962637}

Univariate Polynomial Equations: In general, the fsolve command finds one real solution. However, for a univariate
polynomial equation, the fsolve command returns all real roots.

> equation3 := y4 -3 y2 —2y+1:
> fsolve(equation3, y)
0.3365322739, 1.940392664

Controlling the Number of Solutions: To limit the number of roots returned, specify the maxsols option.
> fsolve(equation3, y, maxsols'= 1)

0.3365322739
To find additional solutions to a general equation, use the avoid option to ignore known solutions.
> fsolve(equation2, z,'avoid = {z= (4.8) })

-2.498755763

Complex Solutions: To search for a complex solution or find all complex and real roots for a univariate polynomial,
specify the complex option for the fsolve command.
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> fsolve(equation3, y,'compleX)

-1.13846246879373 — 0.4850624940594351, -1.13846246879373 + 0.4850624940594351,
0.336532273926790, 1.94039266366067

If the fsolve command does not find any solutions, it is recommended that you specify a range in which to search for
solutions, or specify an initial value.

Range: To search for a solution in a range, specify the range in the calling sequence. The range can be real or complex.
> fsolve(equation2, z, {z = 100..200})
149.2390528
The syntax for specifying a region in the complex plane is lower-left point..upper-right point.
> fsolve(equation3, y, {y = -2 — 1.0}, 'compleX);
-1.13846246879373 — 0.4850624940594351

Initial Values: You can specify a value for each unknown. The fsolve command uses these as initial values for the
unknowns in the numerical method.

> fsolve(equation2, {z =100})
{z=98.98037599} (4.9)

For more information and examples, refer to the fsolve/details help page.

For information on verifying and using solutions returned by the fsolve command, see the following section, Working
with Solutions.

Working with Solutions

Verifying: It is recommended that you always verify solutions (that the solve and fsolve commands return) using the
eval command.

> equation4 := sin(x) = —cos(x):
> solve(equation4)

-—n (4.10)

> eval(equation4, x= (4.10))

J2 (@.11)

> equation5 := cos(z) = %:
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> fsolve(equation5)
-2.498755763 (4.12)
> eval(equation5, {z = (4.12) })
-0.8003983544 = -0.8003983540 (4.13)

For more information, see Substituting a Value for a Subexpression (page 279).

Assigning the Value of a Solution to a Variable: To assign the value of a solution to the corresponding variable as
an expression, use theassign command.

For example, consider the numeric solutionin (4.9), {z = 98.98037599}, found using the starting value z = 100.
> assign((4.9))

>z
98.98037599

Creating a Function from a Solution: The assign command assigns a value as an expression to a name. It does not
define a function. To convert a solution to a function, use the unapply command.

Consider one of the solutions for q to the equation q2 —rs+ % =5.

> solutions:=

solve(q2 —rs+ % =5, q)]

1 -1+J1+4”s+20% 1 1+J1+4Ps+207°
r T2 r

solutions:=

> = unapply/(solutions[1] ,r,s)

_ 1 1+J1+4rs+207°
fi=(rns)>5 »

Here, solutions[1] selects the first element of the list of solutions. For more information on selecting elements, see
Accessing Elements (page 263).

You can evaluate this function at symbolic or numeric values.
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> fix, )

1 -1+J1+4X8y+204
2 X

e

>

J2 (411 +42)

1
2

£(5.7,2.1)
4.032680522

For more information on defining and using functions, see Functional Operators (page 268).

Other Specialized Solvers

In addition to equations and inequations, Maple can solve other equations including:

3

3

Ordinary differential equations (ODEs)
Partial differential equations (PDEs)
Integer equations

Integer equations in a finite field
Linear systems

Recurrence relations

Ordinary Differential Equations (ODESs)

Maple can solve ODEs and ODE systems, including initial value and boundary value problems, symbolically and nu-
merically.

ODE Analyzer Assistant The ODE Analyzer Assistant is a point-and-click interface to the Maple ODE solving
routines.

To open the ODE Analyzer:

From the Tools menu, select Assistants, and then ODE Analyzer.

Maple inserts the dsolve[interactive]() calling sequence in the document. The ODE Analyzer Assistant (Figure 4.3)
is displayed.
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(%] oDE Analyzer Assistant
Differential Equations Conditions Parameters
& gle) _ 7(0)=0 o=
L=1
=2

I Solve Numerically l[ Solve Symbalically ][ Classify

Figure 4.3: ODE Analyzer Assistant

In the main ODE Analyzer Assistant window, you can define ODEs, initial or boundary value conditions, and para-

ax(t)
PR and

meters. To define derivatives, use the diff command. For example, diff (x (t) , t) corresponds to

Ex(t)
dar?

diff (x(t), t, t) correspondsto . For more information on the diff command, see The diff

Command (page 134).
After defining an ODE, you can solve it numerically or symbolically.

To solve a system numerically using the ODE Analyzer Assistant:
1. Ensure that the conditions guarantee uniqueness of the solution.

2. Ensure that all parameters have fixed values.

3. Click the Solve Numerically button.
4

. In the Solve Numerically window (Figure 4.4), you can specify the numeric method and relevant parameters and
error tolerances to use for solving the problem.

5. To compute solution values at a point, click the Solve button.
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Figure 4.4: ODE Analyzer Assistant: Solve Numerically Dialog

To solve a system symbolically using the ODE Analyzer Assistant:
1. Click the Solve Symbolically button.

2. In the Solve Symbolically window (Figure 4.5), you can specify the method and relevant method-specific options
to use for solving the problem.

3. To compute the solution, click the Solve button.
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Figure 4.5: ODE Analyzer Assistant: Solve Symbolically Dialog

When solving numerically or symbolically, you can view a plot of the solution by clicking the Plot button.
* To plot the solution to a symbolic problem, all conditions and parameters must be set.

* To customize the plot, click the Plot Options button to open the Plot Options window.

To view the corresponding Maple commands as you solve the problem or plot the solution, select the Show Maple
commands check box.

You can control the return value of the ODE Analyzer using the On Quit, Return drop-down list. You can select to
return nothing, the displayed plot, the computed numeric procedure (for numeric solutions), the solution (for symbolic
solutions), or the Maple commands needed to produce the solution values and the displayed plot.

For more information, refer to the ODEAnalyzer help page.
The dsolve Command
The ODE Analyzer provides a point-and-click interface to the Maple dsolve command.

For ODEs or systems of ODEs, the dsolve command can find:
* Closed form solutions

¢ Numerical solutions
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¢ Series solutions

In addition, the dsolve command can find:
» Formal power series solutions to linear ODEs with polynomial coefficients

» Formal solutions to linear ODEs with polynomial coefficients

To access all available functionality, use the dsolve command directly. For more information, refer to the dsolve help
page.

Partial Differential Equations (PDEs)

To solve a PDE or PDE system symbolically or numerically, use the pdsolve command. PDE systems can contain
ODEzs, algebraic equations, and inequations.

For example, solve the following PDE symbolically. For help entering a partial derivative, see Example I - Enter a
Partial Derivative (page 51).

>xﬁ%ﬂxw)yf%ﬂxw]=o

X[ﬂ&WJ—y[ixﬂ&WJ=0 (4.14)

> pdsolve((4.14))

f(xy) = _FI(x* +7)

The solution is an arbitrary univariate function applied to X2 + y2

Maple generally prints only the return value, errors, and warnings during a computation. To print information about
the techniques Maple uses, increase the infolevel setting for the command.

To return all information, set infolevel to 5.
> infolevel| pdsolve] :=5 :

> pdsolve((4.14))

Checking arguments ...

First set of solution methods (general or quase general solution)
Second set of solution methods (complete solutions)
Trying methods for first order PDEs

Second set of solution methods successful

f(xy) = _FI(x* +7)

For more information on solving PDEs, including numeric solutions and solving PDE systems, refer to the pdsolve
help page.

Integer Equations

To find only integer solutions to an equation, use the isolve command. The isolve command finds solutions for all
variables. For more information, refer to the isolve help page.
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> isolve( {XZ +y= 13})

Integer Equations in a Finite Field
To solve an equation modulo an integer, use the msolve command. The msolve command finds solutions for all variables.
For more information, refer to the msolve help page.
> msolve( {xz = 1}, 1 3)
{x=1}, {x=12}

Solving Linear Systems

To solve a linear system, use the LinearAlgebra[LinearSolve] command. The LinearSolve command returns the
vector x that satisfies A . x = B. For more information, refer to the LinearAlgebra[LinearSolve] help page.

For example, construct an augmented matrix using the Matrix palette (see Creating Matrices and Vectors (page 120))
in which the first four columns contain the entries of A and the final column contains the entries of B.

(59 44 17 11

10 25 2 100 2

533 61

] Lo 7 100 50
> linearsystem:= :
og 2L 3 2178

10 10 25

51 786

23 9 12 10 75

> LinearAlgebral LinearSolve](linearsystem)

[ 31753441047 |
41858667400

16991806239
8371733480

1489266217
1674346696

262603866
209293337

For more information on using Maple to solve linear algebra problems, see Linear Algebra (page 119).

Solving Recurrence Relations

To solve a recurrence relation, use the rsolve command. The rsolve command finds the general term of the function.
For more information, refer to the rsolve help page.
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> rsolve{fln)= fin-1)+ fin-2), 0)=1, il)= 1}{fin)})
o= (-35 5 +3) (57 3+ (3553

1 1 =\"
2 2 > j ]
4.5 Units, Scientific Constants, and Uncertainty

In addition to manipulating exact symbolic and numeric quantities, Maple can perform computations with units and
uncertainties.

Maple supports hundreds of units, for example, miles, coulombs, and bars, and provides facilities for adding custom
units.

Maple has a library of hundreds of scientific constants with units, including element and isotope properties.

To support computations with uncertainties, Maple propagates errors through computations.

Units

The Units package in Maple provides a library of units, and facilities for using units in computations. It is fully extensible
so that you can add units and unit systems as required.

Note: Some unit operations are available as task templates (see Tools— Tasks— Browse) and through context menus.

Overview of Units

A dimension is a measurable quantity, for example, length or force. The set of dimensions that are fundamental and
independent are known as base dimensions.

In Maple, the base dimensions include length, mass, time, electric current, thermodynamic temperature, amount of
substance, luminous intensity, information, and currency. For a complete list, enter and execute Units[ GetDimensions]().

Complex dimensions (or composite dimensions) measure other quantities in terms of a combination of base dimensions.

mass-length

time

For example, the complex dimension force is a measurement of

Each dimension, base or complex, has associated units. (Base units measure a base dimension. Complex units measure
a complex dimension.) Maple supports over 40 units of length, including feet, miles, meters, angstroms, microns, and
astronomical units. A length must be measured in terms of a unit, for example, a length of 2 parsecs.

Table 4.4 lists some dimensions, their corresponding base dimensions, and example units.

Table 4.4: Sample Dimensions

Dimension Base Dimensions Example Units

Time time second, minute, hour, day, week, month, year,
millennium, blink, lune

Energy joule, electron volt, erg, watt hour, calorie,

2
length”-mass Calorie, British thermal unit

time2

Electric potential volt, abvolt, statvolt

Iength2 -mass

time3 -electric current

For the complete list of units (and their contexts and symbols) available for a dimension, refer to the corresponding
help page, for example, the Units/length help page for the units of length.
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Each unit has a context. The context differentiates between different definitions of the unit. For example, the standard
and US survey miles are different units of length, and the second is a unit of time and of angle. You can specify the
context for a unit by appending the context as an index to the unit, for example, mile[US_survey]. If you do not specify
a context, Maple uses the default context.

Units are collected into systems, for example, the foot-pound-second (FPS) system and international system, or systéme
international, (SI). Each system has a default set of units used for measurements. In the FPS system, the foot, pound,
and second are used to measure the dimensions of length, mass, and time. The unit of speed is the foot/second. In SI,
the meter, kilogram, and second are used to measure the dimensions of length, mass, and time. The units of speed,
magnetic flux, and power are the meter/second, weber, and watt, respectively.

Unit Conversions

To convert a value measured in a unit to the corresponding value in a different unit, use the Units Calculator.

* From the Tools— Assistants menu, select Units Calculator.

The Units Calculator application (Figure 4.6) opens.

__’ -
) Inanlesott Units Calculator

[ —

Convert between over 500 urts of measurement. See Units help mdex for details.

First, select a dimension from the drop-down box. Then select the umits to convert from and to. Clck the
"Perform Unit Conversion” button. The "Convert Back" button converts in the opposite direction.

Convert; |100 Result: |2.831684859
From; |cubic feet (ft~3) adl To- | cubic meters (m~3) |
Dimension: | volume v

[ Perfarm Unit Conversion ] [ Converk Back ]

Figure 4.6: Units Calculator Assistant

To perform a conversion:

1. In the Convert text field, enter the numeric value to convert.

2. In the Dimension drop-down list, select the dimensions of the unit.

3. In the From and To drop-down lists, select the original unit and the unit to which to convert.

4. Click Perform Unit Conversion.

The same conversion can be done with the convert/units command.
> convert(1.0, 'units', ' Ibf ft(radius)', ' N m(radius)")
1.355817948

Using the Units Calculator, you can convert temperatures and temperature changes.
» To perform a temperature conversion, in the Dimension drop-down list, select temperature(absolute).

 To perform a temperature change conversion, in the Dimension drop-down list, select temperature(relative).
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To convert temperature changes, the Units Calculator uses the convert/units command. For example, an increase of
32 degrees Fahrenheit corresponds to an increase of almost 18 degrees Celsius.

> convert(32.0, 'units', ' degF', ' degC")
1777777778

To convert absolute temperatures, the Unit Converter uses the convert/temperature command. For example, 32 degrees
Fahrenheit corresponds to 0 degrees Celsius.

> convert(32, 'temperature', ' degF', ' degC')

0

Applying Units to an Expression

To insert a unit, use the Units palettes. The Units (FPS) palette (Figure 4.7) contains important units from the foot-
pound-second system of units. The Units (SI) palette (Figure 4.8) contains important units from the international
system of units.

W Units (FPS) W Units {SI)
Turmit]  [A2] Tunmit] [m=] 5]
[s1 [powndal]l [#] [kgl [Pzl
[é&] [#1 [/ [&]
|[ poundiorce I 71 [AT [*1
ik’ [c1 el [l
[#P] [poundalft] 1Z] [red] [sr]
[red] Dss] [mol] [x] [he]
Figure 4.7: Units (FPS) Palette | [5T D720 [Me]

Figure 4.8: Units (SI) Palette

To insert a unit:

* In a Units palette, click a unit symbol.
> 3[f]
3 ft

To insert a unit that is unavailable in the palettes:

1. In a Units palette, click the unit symbol [zz] . Maple inserts a Unit object with the placeholder selected.

2. In the placeholder, enter the unit name (or symbol).
For example, to enter 0.01 standard (the default context) miles, you can specify the unit name, mile, or symbol, mi.
> 0.01 [mile]

0.01 mi

The context of a unit is displayed only if it is not the default context.
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Important: In 1-D Math input, the quantity and unit (entered using the top-level Unit command) are a product, not a
single entity. The following calling sequences define different expressions.

> 1*Unit(m) / (2*Unit(s)); > 1*Unit (m) /2*Unit(s) ;
1 m 1
2 s 2

Some units support prefixes. For example, SI units support prefixes to names and symbols. You can specify 1000
meters using kilometer or km. For more information, refer to the Units/prefixes help page.

> 1.5[[kmSI]]
1.5 km

Performing Computations with Units

In the default Maple environment, you cannot perform computations with quantities that have units. You can perform
only unit conversions. For more information about the default environment, refer to the Units/default help page.

To compute with expressions that have units, you must load a Units environment, Natural or Standard. It is recommended
that you use the Standard environment.

> with( Units[ Standard)]) :

In the Standard Units environment, commands that support expressions with units return results with the correct units.

> area = 3ft - %mile

14370939 2
= —— _—m

area= 78125
- (—12 sin(x) +x2)m
S
(-12 sin(x) + &) % (4.15)
> int((4.15), xs)
1 3
(12 cos(x) + 3 X ) m (4.16)

> diff((4.16), xs)
(—12 sin(x) + x2) %

For information on differentiation and integration, see Calculus (page 132).

Changing the Current System of Units

If a computation includes multiple units, all units are expressed using units from the current system of units.
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> 132.25mile
132.25 mi 4.17)

By default, Maple uses the SI system of units, in which length is measured in meters and time is measured in seconds.

- (4.17)
3hour

19.70701333 %

To view the name of the default system of units, use the Units[UsingSystem] command.
> with(Units) :

> UsingSystem( )
SI

To change the system of units, use the Units[UseSystem] command.
> UseSystem(FPS) :
>(4.17) -3m - 1.1kg

1666720741 10 ft* b

Extensibility

You can extend the set of:

* Base dimensions and units
* Complex dimensions

* Complex units

» Systems of units

For more information, refer to the Units|[AddBaseUnit], Units[AddDimension], Units|AddUnit], and
Units[AddSystem] help pages.

For more information about units, refer to the Units help page.

Scientific Constants and Element Properties

Computations often require not only units (see Units (page 99)), but also the values of scientific constants, including
properties of elements and their isotopes. Maple supports computations with scientific constants. You can use the built-
in constants and add custom constants.

Overview of Scientific Constants and Element Properties

The ScientificConstants package provides the values of constant physical quantities, for example, the velocity of light
and the atomic weight of sodium. The ScientificConstants package also provides the units for the constant values,
allowing for greater understanding of the equation as well as unit-matching for error checking of the solution.

The quantities available in the ScientificConstants package are divided into two distinct categories.

 Physical constants
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* Chemical element (and isotope) properties
Scientific Constants

List of Scientific Constants

You have access to scientific constants important in engineering, physics, chemistry, and other fields. Table 4.5 lists
some of the supported constants. For a complete list of scientific constants, refer to the ScientificConstants/Physical-
Constants help page.

Table 4.5: Scientific Constants

Name Symbol
Newtonian_constant of gravitation G
Planck_constant h
elementary charge e
Bohr_radius a[0]
deuteron_magnetic_ moment mu[d]
Avogadro_constant N[A]
Faraday constant F

You can specify a constant using either its name or symbol.
Accessing Constant Definition
The GetConstant command in the ScientificConstants package returns the complete definition of a constant.

To view the definition of the Newtonian gravitational constant, specify the symbol G (or its name) in a call to the
GetConstant command.

> with(ScientificConstants):
> GetConstant('G")

Newtonian_constant_of_gravitation, symbol = G, value = 6.673 10_11, uncertainty = 1.0 10_13, units

m3

- kg s

For information on accessing a constant's value, units, or uncertainty, see Value, Units, and Uncertainty (page 105).

Element Properties

Maple also contains element properties and isotope properties.

Elements

Maple supports all 117 elements of the periodic table. Each element has a unique name, atomic number, and chemical
symbol. You can specify an element using any of these labels. For a complete list of supported elements, refer to the
ScientificConstants/elements help page.

Maple supports key element properties, including atomic weight (atomicweight), electron affinity (electronaffinity),
and density. For a complete list of element properties, refer to the ScientificConstants/properties help page.
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Isotopes

Isotopes, variant forms of an element that contain the same number of protons but a different number of neutrons, exist
for many elements.

To see the list of supported isotopes for an element, use the GetIsotopes command.

> Getlsotopes( 'element' = 'Li")

Li,, Li, Li;, Li, Lig, Lig, Li, o, Li, |, L, ,

Maple supports isotopes and has a distinct set of properties for isotopes, including abundance, binding energy
(bindingenergy), and mass excess (massexcess). For a complete list of isotope properties, refer to the ScientificCon-
stants/properties help page.

Accessing an Element or Isotope Property Definition
The GetElement command in the ScientificConstants package returns the complete definition of an element or isotope.

> GetElement('L1)

3, symbol = Li, name = lithium, names = {lithium}, electronaffinity = [ value = 0.6180, uncertainty
=0.0005, units = eV], atomicweight = [ value = 6.941, uncertainty = 0.002, units = amul,
boilingpoint = [ value = 1615., uncertainty = undefined, units = K], ionizationenergy = [ value

5.3917, uncertainty = undefined, units = eV], density = | value = 0.534, uncertainty

undefined, units = La , electronegativity = [ value = 0.98, uncertainty = undefined, units
cm

1], meltingpoint = [ value = 453.65, uncertainty = undefined, units = K|

> GetElement('Li4]")

Li,, massexcess = [value = 25320.173, uncertainty = 212.132, units = keV'], bindingenergy = [ value
— 4618.058, uncertainty = 212.132, units = keV], atomicmass = | value = 4.027182329 10°,
uncertainty = 227.733, units = uamu]

Value, Units, and Uncertainty

To use constants or element properties, you must first construct a ScientificConstants object.

To construct a scientific constant, use the Constant command.

> G:= Constant('G') :

To construct an element (or isotope) property, use the Element command.

> LiAtomicWeight := Element( 'Li', atomicweight)

LiAtomicWeight := Element(Li, atomicweight)

Value

To obtain the value of a ScientificConstants object, use the evalf command.
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> evalf(G)
1.068912061 10™°
> evalf( LiAtomicWeight)

2.541006042 1072°
Note: The value returned depends on the current system of units.
Units
To obtain the units for a ScientificConstants object, use the GetUnit command.

> GetUnit(G)

£t
Ib 82

> GetUnit{LiAtomicWeight)
Ib

For information on changing the default system of units, for example, from SI to foot-pound-second, see Changing
the Current System of Units (page 102).

Value and Units

If you are performing computations with units, you can access the value and units for a ScientificConstants object by
specifying the units option when constructing the object, and then evaluating the object.

> evalf( Constant('G', units))

3
1.068912061 1072 LZ
Ibs

> evalf(Element('Li[ 5], atomicmass, units) )
1.835022162 10 Ib

Uncertainty

The value of a constant is often determined by direct measurement or derived from measured values. Hence, it has an
associated uncertainty. To obtain the uncertainty in the value of a ScientificConstants object, use the GetError
command.

> GetError(G)
1.0107"3
> GetError( LiAtomicWeight)

3.321080400 1073
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Performing Computations

You can use constant values in any computation. To use constant values with units, use a Units environment as described
in Performing Computations with Units (page 102). For information on computing with quantities that have an uncertainty,
see the following section.

Modification and Extensibility
You can change the definition of a scientific constant or element (or isotope) property.

For more information, refer to the ScientificConstants[ModifyConstant] and ScientificConstants[ModifyElement]
help pages.

You can extend the set of:
¢ Constants
* Elements (and isotopes)

» Element (or isotope) properties

For more information, refer to the ScientificConstants|AddConstant], ScientificConstants|AddElement], and Sci-
entificConstants[AddProperty] help pages.

For more information about constants, refer to the ScientificConstants help page.

Uncertainty Propagation

Some computations involve uncertainties (or errors). Using the ScientificErrorAnalysis package, you can propagate
the uncertainty in these values through the computation to indicate the possible error in the final result.

The ScientificErrorAnalysis package does not perform interval arithmetic. That is, the error of an object does not
represent an interval in which possible values must be contained. (To perform interval arithmetic, use the Tolerances
package. For more information, refer to the Tolerances help page..) The quantities represent unknown values with a
central tendency. For more information on central tendency, refer to any text on error analysis for the physical sciences
or engineering.

Quantities with Uncertainty

Creating: To construct quantities with uncertainty, use the Quantity command. You must specify the value and un-
certainty. The uncertainty can be defined absolutely, relatively, or in units of the last digit. For more information on
uncertainty specification, refer to the ScientificErrorAnalysis|Quantity] help page.

The output displays the value and uncertainty of the quantity.
> with(ScientificConstants): with(ScientificErrorAnalysis):
> Quantity(105, 1.2)

Quantity(105, 1.2)

> Quantity(105, 0.03, 'relative’)
Quantity(105, 3.15) (4.18)

To specify the error in units of the last digit, the value must be of floating-point type.
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> Quantity(105.0, 12, 'uld)
Quantity(105.0, 1.2)

To access the value and uncertainty of a quantity with uncertainty, use the evalf and ScientificError Analysis|GetError]
commands.

> evalf((4.18))
105.

> GetError((4.18))
3.15

Rounding: To round the error of a quantity with uncertainty, use the ApplyRule command. For a description of the
predefined rounding rules, refer to the ScientificErrorAnalysis/rules help page.

> GetError(ApplyRule((4.18), round[2]'))
3.2

Units: Quantities with errors can have units. For example, the scientific constants and element (and isotope) properties
in the ScientificConstants packages are quantities with errors and units.

To construct a new quantity with units and an uncertainty, include units in the Quantity calling sequence.

For an absolute error, you must specify the units in both the value and error.
> with( Units| Standard]) : with(ScientificErrorAnalysis) :
> Quantity(3.5 [m], 0.1 [m])
Quantity(3.5 m, 0.1 m)
For a relative error, you can specify the units in only the value.
> Quantity(3.5m, 0.1, 'relative')
Quantity(3.5 m, 0.35 m)

For information on the correlation between, variance of, and covariance between quantities with uncertainty, refer to
the ScientificErrorAnalysis help page.

Performing Computations with Quantities with Uncertainty

Many Maple commands support quantities with uncertainty.
> g1 := Quantity(31., 2.):

> g2 := Quantity(20., 1.):

Compute the value of the derivative of g1 X+ sin(g2-x) at x = sin(r/4).
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>dl:= diff(ql-x2 + sin(g2-x) ,x)
dl := 2 Quantity(31., 2.) x + cos(Quantity(20., 1.) x) Quantity(20., 1.)

>d2:= eval[dl, X= sin[%]]:

To convert the solution to a single quantity with uncertainty, use the combine/errors command.

> result:= combine(dZ2, 'errors):

The value of the result is:

> evalf(result)
43.74124725

The uncertainty of the result is:

> GetError(result)

14.42690612

Additional Information

For information on topics including:
* Creating new rounding rules,
* Setting the default rounding rule, and

» Creating a new interface to quantities with uncertainty,

refer to the ScientificErrorAnalysis help page.

4.6 Restricting the Domain

By default, Maple computes in the complex number system. Most computations are performed without any restrictions
or assumptions on the variables. Maple often returns results that are extraneous or unsimplified when computing in
the field of complex numbers. Using restrictions, you can more easily and efficiently perform computations in a
smaller domain.

Maple has facilities for performing computations in the real number system and for applying assumptions to variables.

Real Number Domain
To force Maple to perform computations in the field of real numbers, use the RealDomain package.

The RealDomain package contains a small subset of Maple commands related to basic precalculus and calculus
mathematics, for example, arccos, limit, and log, and the symbolic manipulation of expressions and formulae, for ex-
ample, expand, eval, and solve. For a complete list of commands, refer to the RealDomain help page.

After you load the RealDomain package, Maple assumes that all variables are real. Commands return simplified results
appropriate to the field of real numbers.

> with(RealDomain):
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> Simplify(\/7 )

> ln(ex)
X

Some commands that generally return NULL instead return a numeric result when you use the RealDomain package.

1
>(—32)[5J
-2

Complex return values are excluded or replaced by undefined.
> solve(x2 = — 1)

> arcsin(ez)

undefined

Assumptions on Variables

To simplify problem solving, it is recommended that you always apply any known assumptions to variables. You can
impose assumptions using the assume command. To apply assumptions for a single computation, use the assuming
command.

Note: The assume and assuming commands are not supported by the RealDomain package.
The assume Command

You can use the assume command to set variable properties, for example, x::real, and relationships between variables,
for example, x < 0 or x <y. For information on valid properties, refer to the assume help page. For information on the
double colon (::) operator, refer to the type help page.

The assume command allows improved simplification of symbolic expressions, especially multiple-valued functions,
for example, computing the square root.

To assume that x is a positive real number, use the following calling sequence. Then compute the square root of X

> assume(0 < X): \/7

X~
The trailing tilde (~) on the name x indicates that it carries assumptions.

When you use the assume command to place another assumption on x, all previous assumptions are removed.
> assume(x < 0): X
—_ XN

Displaying Assumptions: To view the assumptions on an expression, use the about command.



4.6 Restricting the Domain < 111

> about(x)

Originally x, renamed x~:

is assumed to be: RealRange (-infinity,Open (0))

Imposing Multiple Assumptions: To simultaneously impose multiple conditions on an expression, specify multiple
arguments in the assume calling sequence.

> assume(0 < x, X < 2)

To specify additional assumptions without replacing previous assumptions, use the additionally command. The syntax
of the additionally calling sequence is the same as that of the assume command.

> additionally(x :: integer): about(x)

Originally x, renamed x~:
is assumed to be: 1

The only integer in the open interval (0, 2) is 1.

Testing Properties: To test whether an expression always satisfies a condition, use the is command.

> assume(15 <x, 7 <)): is(100 < xy)
true

The following test returns false because there are values of x and y (x =0, y = 10) that satisfy the assumptions, but do
not satisfy the relation in the is calling sequence.

> assume(X:: nonnegint, 10 <y): is(10 < x+))
false

To test whether an expression can satisfy a condition, use the coulditbe command.

> coulditbe(10 < x + )
true

Removing Assumptions: To remove all assumptions on a variable, unassign its name.

1L 1,

> unassign ('x', 'y")

For more information, see Unassigning Names (page 74).

For more information on the assume command, refer to the assume help page.

The assuming Command

To perform a single evaluation under assumptions on the names in an expression, use the assuming command.

The syntax of the assuming command is <expression> assuming <property or relation>. Properties and relations are
introduced in The assume Command (page 110).

The frac command returns the fractional part of an expression.
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> frac(x) assuming x :: integer
0

Using the assuming command is equivalent to imposing assumptions with the assume command, evaluating the ex-
pression, and then removing the assumptions.

> about(x)

X:

nothing known about this object

If you do not specify the names to which to apply a property, it is applied to all names.

/ 2
> [Zj assuming positive

Assumptions placed on names using the assume command are ignored by the assuming command, unless you include
the additionally option.

> assume(x < 1)

> is(l — X >0) assuming x> -1

false

> is( 1—X> O) assuming additionally, x > -1
true

The assuming command does not affect variables inside procedures. (For information on procedures, see
Procedures (page 297).) You must use the assume command.

> f := proc(x) sqgrt(a”2) + x end proc;

f:=proc(x) sqrt(ar2) + x end proc
> f(1) assuming a > 0
Jd +1
> assume(a > 0): f(1)
a~+1

For more information on the assuming command, refer to the assuming help page.
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This chapter focuses on solving problems in specific mathematical disciplines. The areas described below are not all
that Maple provides, but represent the most commonly used packages. Examples are provided to teach you how to use
the different methods of calculation available in Maple, including tutors, assistants, commands, task templates, plotting,
and context menus.

The examples in this chapter assume knowledge of entering commands and mathematical symbols. For information,
see Entering Expressions (page 16). For information on basic computations, including integer operations and solving
equations, see Basic Computations (page 79).

5.1 In This Chapter

Section Topics

Algebra (page 113) - Performing algebra computations * Polynomial Algebra

Linear Algebra (page 119) - Performing linear algebra » Creating Matrices and Vectors
computations

» Accessing Entries in Matrices and Vectors
» Linear Algebra Computations

* Student LinearAlgebra Package

Calculus (page 132) - Performing calculus computations e Limits

« Differentiation

* Series

* Integration

« Differential Equations

* Calculus Packages

Optimization (page 142) - Performing optimization computations |* Point-and-Click Interface

using the Optimization package « Efficient Computation

* MPS(X) File Support

Statistics (page 146) - Performing statistics computations using |* Probability Distributions and Random Variables

the Statistics package « Statistical Computations

 Plotting

Teaching and Learning with Maple (page 150) - Student and |+ Table of Student and Instructor Resources

Instructor resources for using Maple in an academic setting - Student Packages and Tutors

Clickable MathTM (page 162) - Solve math problems using some |+ Step-by-Step examples
of the interactive methods available in Maple

5.2 Algebra

Maple contains a variety of commands that perform integer operations, such as factoring and modular arithmetic, as
described in Integer Operations (page 82). In addition, it supports polynomial algebra.

For information on matrix and vector algebra, see Linear Algebra (page 119).

113



114 + 5 Mathematical Problem Solving

Polynomial Algebra

A Maple polynomial is an expression in powers of an unknown. Univariate polynomials are polynomials in one unknown,

for example, X - 2x + 13. Multivariate polynomials are polynomials in multiple unknowns, such as

x3y—%xy2+7x

The coefficients can be integers, rational numbers, irrational numbers, floating-point numbers, complex numbers,
variables, or a combination of these types.

>ax2+7x—g

ax2+7x—%b

Arithmetic

The polynomial arithmetic operators are the standard Maple arithmetic operators excluding the division operator (/).
(The division operator accepts polynomial arguments, but does not perform polynomial division.)

Polynomial division is an important operation. The quo and rem commands find the quotient and remainder of a
polynomial division. See Table 5.1. (The iquo and irem commands find the quotient and remainder of an integer division.
For more information, see Integer Operations (page 82).)

Table 5.1: Polynomial Arithmetic Operators

Operation Operator |Example
Addition +

>S(¥+1)+ (38 -5x+2)
X +3+3xX-5x
Subtraction - >(¥+1) - (38 —5x+2)

X¥—1-3X+5x

Multiplication’ * >(X2+1)-(3X3— 5x+ 2)
(¥+1) (38 -5x+2)
Division: i d
R:r’:lzli(r)lrée?uonem an " s quo(2 ¥ + x - 3,3x+5,x)
rem 2 7
L x_L
3 9
> rem(2x2 +x-3,3x+ 5,x)
8
9
Exponentiation’ A S ( 2+ 1)3

(2+1)
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Operation Operator |Example

You can specify multiplication explicitly by entering *, which displays in 2-D Math as - . In 2-D
Math, you can also implicitly multiply by placing a space character between two expressions. In
some cases, the space character is optional. For example, Maple interprets a number followed by a
name as an implicit multiplication.

%In 2-D Math, exponents display as superscripts.

To expand a polynomial, use the expand command.

> expand(B xz-(S x+5)—(x2—2))
9xX +14X +2

If you need to determine whether one polynomial divides another, but do not need the quotient, use the divide command.
The divide command tests for exact polynomial division.

> divide(x4);+x3);—x2 );+13 X+13 x— 13+y-x2+x~y—y, x2+x— 1)
true

Important: You must insert a space character or a multiplication operator ( - ) between adjacent variables names.
Otherwise, they are interpreted as a single variable.

For example, X does not divide the single variable Xy.

> divide(xy, X)

false
But, x divides the product of x and .
> divide(x y, X); divide(x-y, X)
true
true

For information on polynomial arithmetic over finite rings and fields, refer to the mod help page.
Sorting Terms
To sort the terms of a polynomial, use the sort command.
> pl:=x2+x3—x—f—x4

pl =X X —x+ X
> sort(pl)

XX —x

Note: The sort command returns the sorted polynomial, and updates the order of the terms in the polynomial.

The terms of p1 are sorted.
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> pl
XX+ X = x

To specify the unknowns of the polynomial and their ordering, include a list of names.

> sort(a2x3+x2 +xa+a+b, [a])

Xa+xa+a+xX +b

>sort(a2x3+x2+xa+a+b,[x, b])

X +X¥ +ax+b+a

By default, the sort command sorts a polynomial by decreasing total degree of the terms.
> p2=xX’+y} X7
> sort(p2,[x, 1)

XV +xX+y

The first term has total degree 4. The other two terms have total degree 3. The order of the final two terms is determined
by the order of their names in the list.

To sort the terms by pure lexicographic order, that is, first by decreasing order of the first unknown in the list option,
and then by decreasing order of the next unknown in the list option, specify the 'plex’ option.

> sort(p2, [x,y], 'pleX)
X4y +y
For information on enclosing keywords in right single quotes ('), see Delaying Evaluation (page 285).

The first term contains X to the power 3; the second, X to the power 2; and the third, X to the power 0.
Using context menus, you can perform operations, such as sorting, for polynomials and many other Maple objects.

To sort a polynomial:

—_—

. Right-click (Control-click, for Macintosh) the polynomial.
2. The context menu displays. From the Sorts menu, select:
* Single-variable, and then the unknown

* Two-variable (or Three-variable), Pure Lexical or Total Degree, and then the sort priority of the unknowns.

See Figure 5.1.
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3 3 1

Yy 4y Cut Ctrl+X
Copy Ctrl+C
Copy Special L4
Paste Ctrl+V
Explore

Apply a Command

Assign to a Mame

Coefficients L4
Collect L4
Combine L4
Differentiate L4

Evaluate at a Point

Factor

Integrate L4

Lirnit

Plots g

Series g

Sirmplify g

Solve g

Complex Maps L

Constructions g

Conversions g

Integer Functions L

Integral Transfoerms L

Language Conversions L

Optimization L

Sequence g

Sorts ' Single-variable ¥

Units ' Two-variable ¥ Pure Lexical ¥ Xy
2-D Math N Total Degree | Y, X D}
Create Task

Figure 5.1: Sorting a Polynomial Using a Context Menu
Maple sorts the polynomial.

In Worksheet mode, Maple inserts the calling sequence that performs the sort followed by the sorted polynomial.

>+ + X
> sort( XA3+yA3+xA2*yA2, [y, x],plex)

VX + X

You can use context menus to perform operations on 2-D Math content including output. For more information, see
Context Menus (page 54) (for Document mode) or Context Menus (page 69) (for Worksheet mode).
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Collecting Terms

To collect the terms of polynomial, use the collect command.
> Collect(Z axy+ szy— zy2 +az-13by+ 32/2,)/)

(—Z+i]y2+(2ax+cx2—13 b)y+az

Coefficients and Degrees
Maple has several commands that return coefficient and degree values for a polynomial. See Table 5.2.

Table 5.2: Polynomial Coefficient and Degree Commands

Command |Description Example
coeff Coefficient of specified degree term
> Coeff(%)?— 2 X+5, x3)
1
2
Icoeff Leading coefficient 1
> Icoeff( Ex3—2 x+5)
1
2
tcoeff Trailing coefficient 1
> tcoeff[ EX3_2 x+5]
5
coeffs Sequence of all coefficients, in one-to-one 1 X3
correspondence with the terms > coeffs ( B} -2 x+ 5)
Note: It does not return zero coefficients 1
5! - 2’ E
degree (Highest) degree
> degree( %)?—2 x+5]
3
Idegree Lowest degree term with a non-zero 1 3
coefficient > Idegree[ B -2 X)
1

Factorization

To express a polynomial in fully factored form, use the factor command.
> factor( X 1)

(x—1) (x+1) (¥ +1)
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The factor command factors the polynomial over the ring implied by the coefficients, for example, integers. You can
specify an algebraic number field over which to factor the polynomial. For more information, refer to the factor help
page. (The ifactor command factors an integer. For more information, see Integer Operations (page 82).)

To solve for the roots of a polynomial, use the solve command. For information on the solve command, see Solving
Equations and Inequations (page 86). (The isolve command solves an equation for integer solutions. For more inform-
ation, see Integer Equations (page 97).)

Other Commands
Table 5.3 lists other commands available for polynomial operations.

Table 5.3: Select Other Polynomial Commands

Command Description

content Content (multivariate polynomial)

compoly Decomposition

discrim Discriminant

ged Greatest common divisor (of two polynomials)
gedex Extended Euclidean algorithm (for two polynomials)
CurveFitting[Polynomiallnterpolation] Interpolating polynomial (for list of points)

See also the CurveFitting Assistant (Tools — Assistants
— Curve Fitting)

lem Least common multiple (of two polynomials)

norm Norm

EPROM Pseudo-remainder (of two multivariate polynomials)
primpart Primitive part (multivariate polynomial)

randpoly Random polynomial
PolynomialTools[IsSelfReciprocal] Determine whether self-reciprocal

resultant Resultant (of two polynomials)

roots Exact roots (over algebraic number field)

sqrfree Square-free factorization (multivariate polynomial)

Additional Information

Table 5.4: Additional Polynomial Help

Topic Resource

General polynomial information ?polynom help page

PolynomialTools package ?PolynomialTools package overview help page

Algebraic manipulation of numeric polynomials ?SNAP (Symbolic-Numeric Algorithms for Polynomials) package
overview help page

Polynomial information and commands Maple Help System Table of Contents:
Mathematics— Algebra— Polynomials section

5.3 Linear Algebra
Linear algebra operations act on Matrix and Vector data structures.

You can perform many linear algebra operations using task templates. In the Task Browser (Tools — Tasks —
Browse), expand the Linear Algebra folder.
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Creating Matrices and Vectors

Creating Matrices

You can create a Matrix using
* The Matrix command
* The angle bracket shortcut notation

* The Matrix palette (see Figure 5.2).

When creating a Matrix using the Matrix command, there are several input formats available. For example, enter a list
of lists. The dimensions of the matrix are inferred from the number of entries given.

> Matrix( [1,m 0], [ez, sin(t), 827], [0, 0, Se]D
1 T 0
2 oo 87
e~ sin(t) >
0 0 5e

Alternatively, use the angle bracket shortcut, <>. Separate items in a column with commas, and separate columns with
vertical bars, |.

> <1, r, 0|e?, sin(t), 827‘0, 0, 5e>
1 e2 0
n sin(t) O
87
0o %L 5
5 e

For information on the Matrix command options, see Creating Matrices and Vectors with Specific Properties (page 123).

Use the Matrix palette to interactively create a matrix without commands:

W Matkrix
Rows: 2 3
Columns: 2 3

| Choose... |
Type: | Custom values ¥ |
Shape: i\ﬁ)

Data bype: | Any - |

o

| Insert Matrix |

Figure 5.2: Matrix Palette

In the Matrix palette, you can specify the matrix size (see Figure 5.3) and properties. To insert a matrix, click the Insert
Matrix button.
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W Matrix

Rows:
Caolumns:

Choose, ..

!!

Type:
Shape:

Data bype:

- HEE

3 3 {5hift: x10; Control; x1007%

Figure 5.3: Matrix Palette: Choosing the Size

After inserting the matrix:

1. Enter the values of the entries. To move to the next entry placeholder, press Tab.

2. After specifying all entries, press Enter.

1 e 0
m sin(t) O
0 % S5e

Creating Vectors

You can create a Vector using angle brackets (< >).

To create a column vector, specify a comma-delimited sequence, <a, b, ¢>. The number of elements is inferred from

the number of expressions.
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> (1,2, 3)

To create a row vector, specify a vertical-bar-delimited (|) sequence, <a | b | ¢>. The number of elements is inferred
from the number of expressions.

>(1]2]3)
[123]
For information on the Vector command options, refer to the Vector help page.

You can also create vectors using the Matrix palette. If either the number of rows or number of columns specified is
1, then you have the option of inserting a matrix, or inserting a vector of the appropriate type. See Figure 5.4.

W Matrix

—

[¢ls]| <]

Raows:
Columns: 27

| choose... |
Type: [ Custom values T_;ﬁ'
Shape: [ Any v_;ﬁ'
Data type: [ Any T_;ﬁ'

=== Insert Vector[row] -

= Insert Matrix —

U Insert Vector[raw]
I |

Figure 5.4: Insert Matrix or Insert Vector
Viewing Large Matrices and Vectors

Matrices 10 x 10 and smaller, and vectors with 10 or fewer elements, display in the document. Larger objects are
displayed as a placeholder.

For example, insert a 15 x 15 matrix.

In the Matrix palette:
1. Specify the dimensions: 15 rows and 15 columns.
2. In the Type drop-down list, select a matrix type, for example, Random.

3. Click Insert Matrix. Maple inserts a placeholder.

15 x 15 Matrix
Data Type: anything
Storage: rectangular
Order: Fortran_order

To edit or view a large matrix or vector, double-click the placeholder. This launches the Matrix Browser. See Figure 5.5.
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123

Browse Matrix

1 2 3 4 5 & 7

1 |44 0 33 -29 20 -4 35 i

292 -41 -43 el -4t 27 -26

3 |73 -79 68 a1 35 15 -36

4 -39 el o8 35 -54 15 =0

5 g2 45 -43 30 -17 63 -94

& |11 -10 -85 20 -23 ] -97

76l -5 -85 39 78 -51 -33 3

g |28 47 19 -35 23 =1 -36 ]

9 |48 -S4 25 26 -67 35 -69

1o |63 -T2 17 -7 28 -33 &9

11 |27 -79 31 13 -31 -19 -15

12 |38 75 39 32 -36 -55 2

13 |2 -35 92 45 -33 71 -33

14 |34 -19 -2 -G a1 -50 29

o - . § . m—

<] I | [#]

Figure 5.5: Matrix Browser

To modify the entries using the Matrix Browser:
1. Select the Table tab.
2. Double-click an entry, and then edit its value. Press Enter.

3. Repeat for each entry to edit.

4. When you have finished updating entries, click Done.

You can view the matrix or vector as a table or as an image, which can be inserted into the document. For more inform-

ation, refer to the MatrixBrowser help page.

To set the maximum dimension of matrices and vectors displayed inline:

 Use the interface command with the rtablesize option.

For example, interface(rtablesize = 15).

For more information, refer to the interface help page.

Creating Matrices and Vectors with Specific Properties

By default, matrices and vectors can store any values. To increase the efficiency of linear algebra computations, create
matrices and vectors with properties. You must specify the properties, for example, the matrix shape or data type, when

defining the object.

The Matrix palette (Figure 5.2) supports several properties.

To specify the matrix type:

 Use the Shape and Type drop-down lists.
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To specify the data type:
» Use the Data type drop-down list.

For example, define a diagonal matrix with small integer coefficients.
In the Matrix palette:

1. Specify the size of the matrix, for example, 3 x 3.

2. In the Shapes drop-down list, select Diagonal.

3. In the Data type drop-down list, select integer[1].

4. Click the Insert Matrix button.
5

. Enter the values in the diagonal entries.

=23 0 O
> 0 17 0
0 0 32

You cannot specify properties when defining vectors using the angle-bracket notation. You must use the Vector con-
structor.

To define a column vector using the Vector constructor, specify:
* The number of elements. If you explicitly specify all element values, this argument is not required.
* A list of expressions that define the element values.

» Parameters such as shape, datatype, and fill that set properties of the vector.

The following two calling sequences are equivalent.

> Vector([0,0,0])

> Vector(3, 'shape' ='zero')

To create a row vector using the Vector constructor, include row as an index.
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> Vector[row](3,'fill'=1)

[111]

> Vector[row]([127,0, 34], 'datatype' = 'integer[1]")
[127 0 34|

The Matrix palette does not support some properties. To set all properties, use the Matrix constructor.

To define a matrix using the Matrix constructor, specify:
» The number of rows and columns. If you explicitly specify all element values, these arguments are not required.
A list of lists that define the element values row-wise.

» Parameters such as shape, datatype, and fill that set properties of the matrix.

For example:
> Matrix([[1,2,3],[4,5,6]])

123
456

The Matrix palette cannot fill the matrix with an arbitrary value. Use the fill parameter.
> Matrix(3,4,[[1,2,3],[4,5,6]],'fill =2 + 1)

1 2 3 2+1
4 5 6 2+I
2+12+12+12+1

For more information on the constructors, including other calling sequence syntaxes and parameters, refer to the storage,
Matrix, and Vector help pages.

See also Numeric Computations (page 132).
Accessing Entries in Matrices and Vectors

Matrices

To select an entry in a Matrix, enter the matrix name with a sequence of two non-zero integer indices, row first.
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> M:= (-4.3,-6.7,1.9|2.9,-1.2, 9.6/9.3,-8.0,-9.2)

-43 29 93
M:=| -6.7 -1.2 -8.0
1.9 9.6 -9.2
>M[1, 3]
9.3

To select an entire row, enter a single index; to select an entire column, enter first the entire range of rows, 1 ..-1, then
the column index.

> M[2]
-6.7 -1.2 -8.0
>M[1.-1,1]
-4.3
-6.7
1.9

Similarly, you can access submatrices. Enter the indices as a list or range.
>M[2.3,1.2]

-6.7 -1.2
1.9 9.6

Vectors

To select an entry in a vector, enter the vector name with a non-zero integer index.
>a:=<85.3,47.1,59.9,38.1>

85.3
47.1
59.9
38.1

>all]
85.3

Negative integers select entries from the end of the vector.
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>al—1]
38.1

To create a Vector consisting of multiple entries, specify a list or range of integers in the index. For more information,
refer to the set and range help pages.

>al[1,2]]
85.3
47.1
>aq[2.4]
47.1
59.9
38.1

Linear Algebra Computations

Maple has extensive support for linear algebra. You can perform many matrix and vector computations using context
menus. Matrix operations such as multiplication and inverses can be done with the basic matrix arithmetic operators.
The LinearAlgebra package provides the full range of Maple commands for linear algebra and vector space computa-
tions, queries, and linear system solving.

Matrix Arithmetic

The matrix and vector arithmetic operators are the standard Maple arithmetic operators up to the following two differ-
ences.

» The scalar multiplication operator is the asterisk (*), which displays in 2-D Math as - . The noncommutative matrix
and vector multiplication operator is the period (.).

» There is no division operator (/) for matrix algebra. (You can construct the inverse of a matrix using the exponent

1)

Table 5.5 lists the basic matrix operators.

93 43
19 37

48 20
19 37

:C:= (23,6):

Table 5.5: Matrix and Vector Arithmetic Operators

Operation Operator |Example
Addition + >A+B

141 63
38 74
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Operation Operator |Example
Subtraction — >A—B
45 23
0 0
Multiplication . > AC
2397
659
Scalar Multiplication1 * >12A
1116 516
228 444
>4-C
92
24
Exponentiation® " > A3
986548 613868
271244 187092
> B!
37 5
1396 349
19 12
1396 349

You can specify scalar multiplication explicitly by entering *, which displays in 2-D Math as - .
In 2-D Math, you can also implicitly multiply a scalar and a matrix or vector by placing a space

character between them. In some cases, the space character is optional. For example, Maple interprets
a number followed by a name as an implicit multiplication.

’In 2-D Math, exponents display as superscripts.

A few additional matrix and vector operators are listed in Table 5.6.

Define two column vectors.
>d:=<1,2,3>:e:= <4,5,6>:

Table 5.6: Select Matrix and Vector Operators

Operation Operator Example
Transpose A > 44T

[123]
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Operation Operator Example
Hermitian Transpose Ao ! %H
7 1 21|
34+412-1
-1 3-41
21 2+1
Cross Product &x* > with(LinearAlgebra):
(3-D vectors only)
Y >d&xe
-3
6
-3
lExponential operators display in 2-D Math as superscripts.
2After loading the LinearAlgebra package, the cross product operator is available as the infix
operator &x . Otherwise, it is available as the LinearAlgebra[CrossProduct] command.

For information on matrix arithmetic over finite rings and fields, refer to the mod help page.

Point-and-Click Interaction
Using context menus, you can perform many matrix and vector operations.

Matrix operations available in the context menu include the following.

» Perform standard operations: determinant, inverse, norm (1, Euclidean, infinity, or Frobenius), transpose, and trace
» Compute eigenvalues, eigenvectors, and singular values

» Compute the dimension or rank

¢ Convert to the Jordan form, or other forms

» Perform Cholesky decomposition and other decompositions
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For example, compute the infinity norm of a matrix. See Figure 5.6.

18735.6985 349723 234937
9859.459  798124.14089

Copy Special ]
Paste Chrl+y

Ewvaluate and Display Inline  Chrl4+=

Explore

Apply a Command

Approxirmate ]
Assign to a Mame

Browse

Eigenwalues, etc »

Map Command Onka
1

Euclidean

Marm
Flots
Select Elements infinity

Frobenius %

Saolvers and Forms

r v v v w

Standard Operations

Canversians

Curve Fitting

Export As

In Place Options

Language Canversions

Map Integer Functions Onka

* v T T Ww w

Queries

2-D Math 3
Figure 5.6: Computing the Infinity Norm of a Matrix

In Document mode, Maple inserts a right arrow and the name of the computation performed, followed by the norm.

187356985 3497232534987 | infinity-nom
—
PE59.459  TO8124.14089

5.0798359990 10°

Vector operations available in the context menu include the following.
* Compute the dimension

* Compute the norm (1, Euclidean, and infinity)

» Compute the transpose

¢ Select an element

For more information on context menus, see Context Menus (page 54) (for Document mode) or Context Menus (page 69)
(for Worksheet mode).

LinearAlgebra Package Commands

The LinearAlgebra package contains commands that construct and manipulate matrices and vectors, compute standard
operations, perform queries, and solve linear algebra problems.
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Table 5.7 lists some LinearAlgebra package commands. For a complete list, refer to the Linear Algebra/Details help

page.

Table 5.7: Select LinearAlgebra Package Commands

Command Description

Basis Return a basis for a vector space

CrossProduct Compute the cross product of two vectors
DeleteRow Delete a row or rows of a matrix

Dimension Determine the dimension of a matrix or a vector
Eigenvalues Compute the eigenvalues of a matrix

Eigenvectors Compute the eigenvectors of a matrix
FrobeniusForm Reduce a matrix to Frobenius form
GaussianElimination Perform Gaussian elimination on a matrix
HessenbergForm Reduce a square matrix to Hessenberg form
HilbertMatrix Construct a generalized Hilbert matrix

IsOrthogonal Test if a matrix is orthogonal

LeastSquares Compute the least-squares approximationto A . x=b
LinearSolve Solve the linear system A .x=Db

MatrixInverse Compute the inverse of a square matrix or pseudo-inverse of a non-square matrix
QRDecomposition Compute the QR factorization of a matrix
RandomMatrix Construct a random matrix

SylvesterMatrix Construct the Sylvester matrix of two polynomials

For information on arithmetic operations, see Matrix Arithmetic (page 127).

For information on selecting entries, subvectors, and submatrices, see Accessing Entries in Matrices and

Vectors (page 125).

Example: Determine a basis for the space spanned by the set of vectors {(2, 13, -15), (7, -2, 13), (5, -4, 9)}. Express
the vector (25, -4, 9) with respect to this basis.

> with(LinearAlgebra):

>v]:=<2,13, -15>:v2:=<7,—-2,13>:v3:= <5, —4,9>:

Find a basis for the vector space spanned by these vectors, and then construct a matrix from the basis vectors.

> basis := Matrix(Basis([v1,Vv2,Vv3]));

2 7 5
basis := 13 -2 -4
-15 13 9

To express (25, -4, 9) in this basis, use the LinearSolve command.
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> LinearSolve(basis, <25, —4,9>)
170 |
91

285
91

786
91

Numeric Computations

You can very efficiently perform computations on large matrices and vectors that contain floating-point data using the
built-in library of numeric linear algebra routines. Some of these routines are provided by the Numerical Algorithms
Group (NAG®). Maple also contains portions of the CLAPACK and optimized ATLAS libraries.

For information on performing efficient numeric computations using the LinearAlgebra package, refer to the Effi-
cientLinearAlgebra help page.

See also Creating Matrices and Vectors with Specific Properties (page 123) and Reading from Files (page 321).

Student LinearAlgebra Package

The Student package contains subpackages that help instructors teach concepts and allow students to visualize and
explore ideas. These subpackages also contain computational commands.

In the Student[LinearAlgebra] subpackage, the environment differs from that of the LinearAlgebra package in that
floating-point computations are generally performed using software precision, instead of hardware precision, and
symbols are generally assumed to represent real, rather than complex, quantities. These defaults, and others, can be
controlled using the SetDefault command. For more information, refer to the Student[SetDefault] help page.

For information on using Maple as a teaching and learning tool, see Teaching and Learning with Maple (page 150).

5.4 Calculus

The Task Browser (Tools— Tasks—Browse) contains numerous calculus task templates. For a list of tasks, navigate
to one of the related folders, such as Calculus, Differential Equations, Multivariate Calculus, or Vector Calculus.

This section describes the key Maple calculus commands, many of which are used in task templates or available in the
context menus.

For a complete list of calculus commands, refer to the Mathematics (including Calculus, Differential Equations,
Power Series, and Vector Calculus subfolders) and Student Package sections of the Maple Help System Table of
Contents.

Limits
To compute the limit of an expression as the independent variable approaches a value:

1. In the Calculus palette, click the limit item g f

2. Specify the independent variable, limit point, and expression, and then evaluate it. Press Tab to move to the next
placeholder.



5.4 Calculus « 133

For example:

. X
> lim | —
X— 0( sin(x) ]

The limit Command

By default, Maple searches for the real bidirectional limit (unless the limit point is o or -). To specify a direction,
include one of the options left, right, real, or complex in a call to the limit command. See Table 5.8.

Table 5.8: Limits

Limit Command Syntax Output
undefined
(lj > Iimir[l,x=O] /
X X
lim (l] > limit[l,x: 0,'r1'ghl‘] *
x—0t X
Xgn&,(;] > Ilmlt[;,X—O, Ieft’]

Using the limit command, you can also compute multidimensional limits.

> limit[);z, {x= 1,y=oo}]

0
For more information on multidimensional limits, refer to the limit/multi help page.

Numerically Computing a Limit

To numerically compute a limit:

* Use the evalf(Limit(arguments)) calling sequence.
Important: Use the inert Limit command, not the limit command. For more information, refer to the limit help page.
The Limit command accepts the same arguments as the limit command.

For example:

> evalf(Limit[ Cos(xs)irjf);)cm(x) X= 1.225))

0.3020605357

For information on the evalf command, see Numerical Approximation (page 281).

The Limit command does not compute the limit. It returns an unevaluated limit.
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sin(x)
cos(x) + tan(x)

>Limit( , X = 1.225)

lim sin(x)
x—1.225 cos(x) + tan(x)

For more information on the Limit command, refer to the Limit help page.

Differentiation
Maple can perform symbolic and numeric differentiation.

To differentiate an expression:

d o
1. In the Calculus palette, click the differentiation item dx J or the partial differentiation item &x

f .
2. Specify the expression and independent variable, and then evaluate it.

For example, to differentiate X sin(a X) with respect to X:

d .
> dx (xsin(ax))

sin(a x) + xcos(ax) a
You can also differentiate using context menus. For more information, see Context Menus (page 32).

To calculate a higher order or partial derivative, edit the derivative symbol inserted. For example, to calculate the

second derivative of x sin(a x) + X with respect to X:

2
> 4 (xsin(a x)+x2)

dx’

2 cos(ax) a— xsin(a x) al +2

To calculate the mixed partial derivative of Xsin(3 y) + y X

2

. 5
> 2y ox (xsm(3 y)+yx )

3cos(3y)+5 X

Note: To enter another @ symbol, you can copy and paste the existing symbol, or enter d and use symbol completion.

The diff Command

Maple computes derivatives using the diff command. To directly use the diff command, specify the expression to dif-
ferentiate and the variable.
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> xsin(ax + X
xsin(ax) + x° .1

> diff((5.1), x)
sin(ax) + xcos(ax) a+ 2 x (5.2)

For information on equation labels such as (5.1), see Equation Labels (page 74).

You can calculate a higher order derivative by specifying a sequence of differentiation variables. Maple recursively
calls the diff command.

> diff((5.1),x x)
2 cos(a x) a— xsin(a x) at +2 (5.3)
To calculate a partial derivative, use the same syntax. Maple assumes that the derivatives compute.

> diff(xsin(3 y) + Wx,xy)
1

2/x

To enter higher order derivatives, it is convenient to use the syntax diff(f, x$n). This syntax can also be used to compute

3cos(3y) +

the symbolic n'™ order derivative.

For example:

> diff(cos(t), t$ n)
cos[t + % nn)

Differentiating an Operator

You can also specify a mathematical function as a functional operator (a mapping). For a comparison of operators and
other expressions, see Distinction between Functional Operators and Other Expressions (page 269).

To find the derivative of a functional operator:

+ Use the D operator.

The D operator returns a functional operator.
For example, find the derivative of an operator that represents the mathematical function F: x— X c0S(Xx).
First, define the operator F.

1. In the Expression palette, click the single-variable function definition item /=& — ¥,
2. Enter placeholder values.

» To move to the next placeholder, press the Tab key. Note: If pressing the Tab key inserts a tab, click the Tab icon
in the toolbar.

> F:=Xx— xcos(x):
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Now, define the operator, G, that <ns1:XMLFault xmlns:ns1="http://cxf.apache.org/bindings/xformat"><ns1:faultstring xmlns:ns1="http://cxf.apache.org/bindings/xformat">java.lang.OutOfMemoryError: Java heap space</ns1:faultstring></ns1:XMLFault>